Jump to content

NZXT AER2 RGB Fans

Teo182
 Share

HI All 

 

Wondering if anyone can help, Just built my a rig and have 6x NZXT AER2 RGB fans however the RGB is not working and they are not showing in cam... they are spinning however..

 

I believe the control unit can only handle 40 RGB at a time and each fan has 8 so I have dropped a fan however still having no luck. Only have 1 USB header spare on the motherboard so happy to run the 5 fans to use only 1 control unit.

 

Using the below parts.

 

Any help massively appreciated ! 

 

image.png.83c9b1469bead6bda8c8714d281f6946.png

Link to comment
Share on other sites

Link to post
Share on other sites

I'm not all that familiar with the fans, but I suppose they should be about the same as normal ARGB fans, did you daisy chain the ARGB cables and have 1 of them plugged to the ARGB header on the motherboard?

Not an expert, just bored at work. Please quote me or mention me if you would like me to see your reply. **may edit my posts a few times after posting**

CPU: Intel i5-12400 | GPU: Asus TUF RX 6800 XT OC | Mobo: Asus Prime B660M-A D4 WIFI | RAM: Team Delta TUF Alliance 2x8GB DDR4 3200MHz CL16 | SSD: Team MP33 1TB | PSU: MSI MPG A850GF | Case: Phanteks Eclipse P360A |  Cooler: ID-Cooling SE-234 ARGB | OS: Windows 11 Pro | Pcpartpicker: https://pcpartpicker.com/list/wnxDfv
Displays: Samsung Odyssey G5 S32AG50 32" 1440p 165hz | AOC 27G2E 27" 1080p 144hz

Laptop: ROG Strix Scar III G531GU Intel i5-9300H GTX 1660Ti Mobile| OS: Windows 10 Home

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, Dukesilver27- said:

I'm not all that familiar with the fans, but I suppose they should be about the same as normal ARGB fans, did you daisy chain the ARGB cables and have 1 of them plugged to the ARGB header on the motherboard?

Can’t do that, NZXT, like Corsair, uses a proprietary connection and pinout for its ARGB.  You need to plug them into one of NZXTs controllers. 
 

I used a Smart Device V2 to control 9 AER2 RGBs without issue, just had to split the RGB up between the two channels. 

ITX & Ultrawide Enthusiast

Link to comment
Share on other sites

Link to post
Share on other sites

i dont have it plugged in to the ARGB header on the mother board.

 

I have each individual fan daisy chained to each other with the power going to the control unit which is pluged in to a usb header and a sata.. theres no connection for ARGB the break of cable states USB. 

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, GuiltySpark_ said:

Can’t do that, NZXT, like Corsair, uses a proprietary connection and pinout for its ARGB.  You need to plug them into one of NZXTs controllers. 
 

I used a Smart Device V2 to control 9 AER2 RGBs without issue, just had to split the RGB up between the two channels. 

ahh so i cant do it out of the box? need to buy the additional unit ?

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, Teo182 said:

ahh so i cant do it out of the box? need to buy the additional unit ?

I don't know, I don't know exactly what you have the RGB portion of the fans connected to.

ITX & Ultrawide Enthusiast

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, GuiltySpark_ said:

Can’t do that, NZXT, like Corsair, uses a proprietary connection and pinout for its ARGB.  You need to plug them into one of NZXTs controllers. 
 

I used a Smart Device V2 to control 9 AER2 RGBs without issue, just had to split the RGB up between the two channels. 

Ah good to know, glad that I didn't buy corsair fans. Thanks for the info.

Not an expert, just bored at work. Please quote me or mention me if you would like me to see your reply. **may edit my posts a few times after posting**

CPU: Intel i5-12400 | GPU: Asus TUF RX 6800 XT OC | Mobo: Asus Prime B660M-A D4 WIFI | RAM: Team Delta TUF Alliance 2x8GB DDR4 3200MHz CL16 | SSD: Team MP33 1TB | PSU: MSI MPG A850GF | Case: Phanteks Eclipse P360A |  Cooler: ID-Cooling SE-234 ARGB | OS: Windows 11 Pro | Pcpartpicker: https://pcpartpicker.com/list/wnxDfv
Displays: Samsung Odyssey G5 S32AG50 32" 1440p 165hz | AOC 27G2E 27" 1080p 144hz

Laptop: ROG Strix Scar III G531GU Intel i5-9300H GTX 1660Ti Mobile| OS: Windows 10 Home

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, GuiltySpark_ said:

Can’t do that, NZXT, like Corsair, uses a proprietary connection and pinout for its ARGB.  You need to plug them into one of NZXTs controllers. 
 

I used a Smart Device V2 to control 9 AER2 RGBs without issue, just had to split the RGB up between the two channels. 

just googled that device and that is the control unit i have that came with the pack of 3. i dont have the space to connect 2 units so i currently have 3 daisy chained and use the 3 conector to plug them in to 1 channel and the other 2 i have plugged in on there own. still no luck ! 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×