Jump to content

No idea why my fps are so low

Diebnak
 Share

Hi,
first and foremost my setup

 

PC:

CPU AMD Ryzen 9 3950X 16 Core

RAM: Corsair Vengeance LPX 64GB (2x32GB) DDR4 3600MHz C18

GPU: Gigabyte RTX 3080 ti

Mobo: ASUS® TUF X570-PLUS

M.2: 1 TB-SAMSUNG 970 EVO PLU

Screen: Samsung Odyssey G9 (C49G93TSSU)

Cooling: Corsair H115i RGB PRO XT Hydro-Serie

PSU: CORSAIR 1000W

 

I know that the PSU is probably overkill and it's not the moste sensible config ever but i took what i could get my hands on 😅

 

the thing is, my GPU usage is really low when playing games as well as my FPS. In valorant for example i only get around 250 fps somewhat stable and in League only around 180 FPS (2560x1440 and high settings)

now this doesn't sound too bad at first but a buddy of mine has a similarly specced pc mby a bit weaker and gets over 400 fps in both games in 4K resolution and all settings on high which caused me to be concerned about my pc and it's performance

 

just did a quick test while writing this, turns out even on the lowes settings possible i only get like 180ish fps in League

could it be the displayport cable i'm using possibly?

Link to comment
Share on other sites

Link to post
Share on other sites

Try to borrow his cable, and match his settings identically.  You shouldn't have issue, but what does this mean?

 

"similarly specced pc mby a bit weaker "

 

You're hedging a little here. Why don't you post his specs so we can see what he has.  Similar specced means jack shit.

TBD - AMD Ryzen 7 7700x - MSI 6900xt Gaming X Trio - Gigabyte B650 Aorus Pro AX - G. Skill Flare X5 DDR5-6000 32GB - Samsung 980 1TB x3 - Super Flower Leadex V Platinum Pro 850 - ON THE WAY: EK-AIO 360 Basic and ThermalTake Core P3.  Looking forward to building week of Dec 5th.

 

Emma : i9 9900K 5.1Ghz - Gigabyte AORUS 1080Ti - Gigabyte AORUS Z370 Gaming 5 - G. Skill Ripjaws V 32GB 3200Mhz - 750 EVO 512GB + 2x 860 EVO 1TB (RAID 0) - EVGA SuperNova 650 P2 - Thermaltake Water 3.0 Ultimate 360mm - Fractal Design Define R6 - AOC AGON 35" 3440x1440 100Hz - Mackie CR5BT - Corsair Virtuoso SE - Logitech G910, G502 - Cooler Master Universal Graphics Card Holder

 

Plex : Ryzen 5 1600 - Gigabyte B450M-DS3H - G. Skill Ripjaws V 16GB 2400Mhz - MSI 1050Ti 4GB - 840 EVO 256GB + Toshiba P300 3TB - TP-Link AC1900 PCIe Wifi - Cooler Master MasterWatt Lite 500 - Antec Nine Hundred - Samsung 27" + Dell 24" 

 

Raven:  Intel i3 10100F - ASRock H410M-HDV - G. Skill Ripjaws V 16GB 2666Mhz - MSI 1050Ti 4GB - Inland 256GB SSD + Toshiba 2TB HDD - TP-Link AC600 USB Wifi - Gigabyte GP-P450B PSU -  Cooler Master MasterBox Q300L -  Spectre 24" 

 

Other Tech:

- Ubiquiti Amplifi HD mesh wifi

- 2021 Volvo S60 Recharge T8 Polestar Engineered - 415hp/495tq 2.0L 4cyl. turbocharged, supercharged and electrified.

Lenovo 720S Touch 15.6" - i7 7700HQ, 16GB RAM, 512GB NVMe SSD, 1050Ti, 4K touchscreen

MSI GF62 - i7 7700HQ, 16GB 2400 MHz RAM, 256GB NVMe SSD + 1TB 7200rpm HDD, 1050Ti

 

Link to comment
Share on other sites

Link to post
Share on other sites

Did you check ingame Framelimiter,VSync and Refreshrates ? this sounds more like wrong settings than a hardware problem. 

 

It could also be possible that you RAM is not on full Clock speed, had this years ago where i forgot to use D.O.C.P. 

Link to comment
Share on other sites

Link to post
Share on other sites

I've checked the D.o.c.p and tried to disable g-sync as well as VSync. Framelimiters are off atleast for the games i usually play

i even have th RAM overclocked slightly to 3733MHz FPS are still the same.

 

as for the pc of my friend, i don't fully remember although i know that he has an current gen i7 the same RAM and an RTX 3080, also it's not really about his pc just that the comparison raised some concernces about my machine since i'm not getting the performance i should be getting (i think)

Link to comment
Share on other sites

Link to post
Share on other sites

i also did a full cleanup of the GPU drivers and installed the lates ones

Link to comment
Share on other sites

Link to post
Share on other sites

after some research i find out that Valorant is a heavily single thread optimized game even if you have multithread option on. So i believe that the 12Gen i7 just outperfom your 3950X. 

 

here some footage from a user with a 3090. Around the same performance throughout all resolutions.

here some performance comparison 
https://www.cpu-monkey.com/de/compare_cpu-amd_ryzen_9_3950x-vs-intel_core_i7_12700k

Link to comment
Share on other sites

Link to post
Share on other sites

Sounds like Nvidia control panel needs to be told to use the gpu instead of the cpu. Make sure whatever game you're running isn't running on intergrated.

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Meowth LVL255 said:

Sounds like Nvidia control panel needs to be told to use the gpu instead of the cpu. Make sure whatever game you're running isn't running on intergrated.

3950x doesn't have integrated graphics.

TBD - AMD Ryzen 7 7700x - MSI 6900xt Gaming X Trio - Gigabyte B650 Aorus Pro AX - G. Skill Flare X5 DDR5-6000 32GB - Samsung 980 1TB x3 - Super Flower Leadex V Platinum Pro 850 - ON THE WAY: EK-AIO 360 Basic and ThermalTake Core P3.  Looking forward to building week of Dec 5th.

 

Emma : i9 9900K 5.1Ghz - Gigabyte AORUS 1080Ti - Gigabyte AORUS Z370 Gaming 5 - G. Skill Ripjaws V 32GB 3200Mhz - 750 EVO 512GB + 2x 860 EVO 1TB (RAID 0) - EVGA SuperNova 650 P2 - Thermaltake Water 3.0 Ultimate 360mm - Fractal Design Define R6 - AOC AGON 35" 3440x1440 100Hz - Mackie CR5BT - Corsair Virtuoso SE - Logitech G910, G502 - Cooler Master Universal Graphics Card Holder

 

Plex : Ryzen 5 1600 - Gigabyte B450M-DS3H - G. Skill Ripjaws V 16GB 2400Mhz - MSI 1050Ti 4GB - 840 EVO 256GB + Toshiba P300 3TB - TP-Link AC1900 PCIe Wifi - Cooler Master MasterWatt Lite 500 - Antec Nine Hundred - Samsung 27" + Dell 24" 

 

Raven:  Intel i3 10100F - ASRock H410M-HDV - G. Skill Ripjaws V 16GB 2666Mhz - MSI 1050Ti 4GB - Inland 256GB SSD + Toshiba 2TB HDD - TP-Link AC600 USB Wifi - Gigabyte GP-P450B PSU -  Cooler Master MasterBox Q300L -  Spectre 24" 

 

Other Tech:

- Ubiquiti Amplifi HD mesh wifi

- 2021 Volvo S60 Recharge T8 Polestar Engineered - 415hp/495tq 2.0L 4cyl. turbocharged, supercharged and electrified.

Lenovo 720S Touch 15.6" - i7 7700HQ, 16GB RAM, 512GB NVMe SSD, 1050Ti, 4K touchscreen

MSI GF62 - i7 7700HQ, 16GB 2400 MHz RAM, 256GB NVMe SSD + 1TB 7200rpm HDD, 1050Ti

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Dedayog said:

3950x doesn't have integrated graphics.

Good point, I've also found that power options can reduce performance significantly. Maybe try looking into that. OEMs like to put their own power optimizers that mess with the entire system *coughdellcough*

Link to comment
Share on other sites

Link to post
Share on other sites

I did some benchmarks just for a sanity check and it seem the hardware runs well within expectations, I'm honestly completely out of ideas...

checked the powersettings as well tried different ones and even tinkered a bit with them myself

 

Overclocking doesn't change anything as well.

Did a fresh install of chipset drivers too.

Link to comment
Share on other sites

Link to post
Share on other sites

just noticed another weird behaviour, when i start a game i get reasonable fps which drop after a few seconds

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×