Jump to content

HP pavillion laptop with RTX 3050 crashing

cpu - ryzen 5 5600h

gpu - rtx 3050

windows 11 22h2

 

Hi guys, i've been tormented with this laptop that i gifted my cousins which was working perfectly fine and running games when i bought it and one day i get a call that thre game keeps crashing on startup. No matter what game it is, it crashes on either the loading screen or when i proceed to get into a match or game.

Updated the graphics drivers for the nvidia gpu and amd iGPU as well, windows updates are all done even the additional ones. i've even added another 8gb stick of ram {now total 16gb} but it doesnt solve my problem.

Stress tested the gpu with furmark for about an hour and it didnt crash.

Re-installed windows as well, installed drivers from HP product page, didnt make a difference.

If i run the games on cpu by unplugging the power or selecting the iGPU the games do run even though the fps are terrible the games dont crash but as soon as i plug in the power they crash.

the most common error message says something like 'exiting due to d3d device being lost'.

The support that i got from HP service center was laughable as a person from their tech team literally told me "i cant help you when it comes to games" [bcz a laptop with rtx 3050 being used for gaming is simply absurd and unbelievable to them i guess] and returned the laptop as it is.

PLEASE HELP i can not find the source of this issue.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Get GeForce experience running, get drivers from Nvidia, same with Radon control settings for the iGPU in the 5600H. Do FULL INSTALLS on both.

Link to comment
Share on other sites

Link to post
Share on other sites

i've already done all those things, geforce updates. studio driver, game ready driver. For AMD i installed the AMD software adrenalin edition with the factory reset option enabled that removed the previous drivers before installing the new ones.

tried over clocking and underclocking the gpu as well but didn't help.

ryzen master gives a message that cpu is not supported si it doesnt even start.

the AMD software runs after installation for the first few times and then stopss working and shows a message that says the driver vesion is incompatible which i updated previously from the same app itself.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×