Jump to content

esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

EricW
 Share

Got a HiLetGo node mcu with the esp8266.  Got that error message using the arduino ide Ubuntu 22.04.

 

So after looking online, I have tried a lot of the solutions.

 

I tried all my usb a ports using 3 different cables. The strange thing is that it used to give me two options for serial ports and now it is only giving me one.

 

I am holding down the flash button when uploading the example code blink.

 

Under the tools section, I used the auto format.

 

I tried to install the drivers, but I'm not sure if I'm doing it correctly, or even downloaded the right thing. (I tried to run the make file in the terminal but that gave a bunch of command not found error) https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers?tab=downloads --> https://www.kernel.org/

Of course, it could be that all three cables happens to only deliver power. (I don't remember where it was originally for and there is nothing else to test them with)

Also, it says to set the buad rate to 9600. I forgot if it is the same thing as the upload speed under tools, but that is 115200, and there is no opeion for 9600

 

I have nothing connected except for the cable, and I do have breadboard and wires. Thanks!

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×