Jump to content

PC not giving a display

Oh boy, I think i'm in a bit of trouble

I tried to do the secure boot for windows 11 through the bios and my pc never booted up.

When I searched for some solutions I found the common take out and put back in the cmos battery and the short Jbat1 pins however I stupidly thought you had to do this when the pc was on and power up.

So I did, the pc then turned off but I can still turn it on but there is still no display.

Is my only solution to get a new MOBO?

SPECS:

Ryzen 5 5600x
MOBO: MSI b450m-pro-vdh max
Gpu: Gigabyte 1660 super
Ram: 16gb T-force
 

Link to comment
Share on other sites

Link to post
Share on other sites

Do the CMOS thing with the PC off and make sure to keep it out for at least a minute.  Reseat you're RAM while you're at it.  This should reset everything on the board.

The sign is a subtle joke. The shop is called "Sneed's Feed & Seed", where feed and seed both end in the sound "-eed", thus rhyming with the name of the owner, Sneed. The sign says that the shop was "Formerly Chuck's", implying that the two words beginning with "F" and "S" would have ended with "-uck", rhyming with "Chuck". So, when Chuck owned the shop, it would have been called "Chuck's Feeduck and Seeduck".

Link to comment
Share on other sites

Link to post
Share on other sites

No, I still had no display after taking out and putting back in the cmos battery and reseating the ram

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×