Jump to content

Youtube and Steam running slow despite trying EVERYTHING?

Mr Grinch
 Share

Go to solution Solved by manikyath,

reinstall the drivers for your network interface.

Hello All,

this is my first time posting here and I really enjoy the LTT channel and all of it's content.  Therefore I figured this would be among the best places to ask this question and hopefully find an answer. 

If this issue has popped up once before on another post, I apologize and will promptly delete this post or request it deleted.  

I thank you all for your time in helping me look through this issue.  

 

What's going on:

YouTube is running painfully slow for some unknown reason.  Constantly stops and buffers even for 1080p even though my ISP can very easily handle 4K. Steam is also behaving strangely and has been very slow lately and fails to load preview images.  My PC is 2, going on 3 years old now and has never had this problem before.  And it is only effecting my PC, nothing else at all.  My Laptop has no issues, my Phone has no issues, My Smart TVs too have no issues.  Only this PC and I have no earthly idea what's causing it.  

  • Gigabit ISP so it's definitely not a Bandwidth.
  • No other Devices having these issue.
  • No other streaming platform has this issue, only YouTube has the buffer of doom. 
  • Steam acting slow for some reason.  Nothing enough to cause performance issues but enough to raise concerns.
  • My PC runs Windows 10 but so does my Laptop and the laptop has no issues at all. 
  • PC is hardwired to the router via Ethernet Cord Cat 6.

What's in my PC (I don't think it matters for YouTube but just incase something's off that I don't know about)

  • CPU - Ryzen 9 3900X 12-Core
  • MOBO - Auros X570 Master
  • GPU - RTX 3090 MSI brand, latest driver
  • RAM - 32 GB, XMP Enabled (16 x 16)
  • PSU - EVGA 850W Gold
  • OS - Windows 10, heard bad things about 11 so I have not switched yet.  I do not plan to until the issues are fixed with that OS. 

What I've tried so far:

  • Tried watching YouTube on this PC on Google Chrome, Internet Explorer as well as the Dedicated YouTube App.  No dice. 
  • Tried changing the YouTube URL.  No dice. 
  • Tried lowering the Quality but it still buffers (Also 480p makes my eyes bleed)
  • Have tried clearing the cache completely
  • I have adjusted Security settings, trying both strict and wide open.  The only thing I haven't tried yet is DMZ-ing the PC but I do not want to risk that. 
  • I have even gone so far as to block the CDN IPs and No Dice. 
  • After trying all of that I concluded that there must have been something somewhere in the PC that I messed up somehow but I have no idea where it even is so I went and did a full scrub of the PC and BIOS and did a fresh install of all things. and it still does not work even after retrying all of the steps again.  

 

So yeah, I am completely stumped on this.  It was working just fine all this time until suddenly it's not?  All other devices having no issues tells me it's not an issue with ISP or Internet settings, or its an issue with internet settings that is only effecting my primary PC for some reason.  I have also given thought into procuring a VPN but with the way things are at the moment I am unsure it will help?

 

Is there any way  to fix this? Or will I be forced to outright build a new PC or something? lmao.

 

Thank you very much for your time in looking this over.  I hope I can find a solution.  I can always just watch YouTube on my other devices but I built the whole PC so I want the whole PC to work, ya know?

Link to comment
Share on other sites

Link to post
Share on other sites

Oh my god that did it.  THANK YOU.  

I forgot to mention it but I did check the drivers in Device manager and everything was showing as "This is the latest driver", even though they were all from 2020, 

but surely enough I googled Network Interface and pulled an Intel link that was updated just 2 months ago.  Popped it in and now everything appears to be running perfectly fine.  

 

My only question now is, 

WHY WERE THESE DRIVERS NOT UP TO DATE ON A BRAND NEW INSTALL??? 

     Like, this was a fresh download and everything lol...

Hours of anguish and turmoil for such a simple fix lmao

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×