Jump to content

Phone won't turn on or charge after years in storage

_Froyo
 Share

I know this is a long shot, but I don't know where else to turn.

I was doing some cleaning the other day and found an old phone of mine, an LG L41C. I recall it having some of my files on its internal storage, so I tried to start it up to see if the files were still there. It had been about 3-4 years since I had last used the thing, but last time I did, it worked just fine. However, now it won't turn on or charge. I've tried everything, from cleaning the charging port, to holding volume up / down + power, to even buying a new battery, but nothing gets this thing to budge. I was wondering if anyone here had any ideas to get it to work. Any help would be appreciated.

Link to comment
Share on other sites

Link to post
Share on other sites

If the phone has been in area where exposure to moisture is possible, that would explain it, and getting it to run again isn't all that likely in that scenario. Some say you can dry out moisture by putting it in a rice bed, but I'm not sure if that will fix any moisture related damage.

 

And just because it wasn't open to the weather means nothing. Extreme temperature changes can form condensation inside a device.

MODERATE TO SEVERE AUTISTIC, COMPLICATED WITH COVID FOG

 

Due to the above, I've likely revised posts <30 min old, and do not think as you do.

THINK BEFORE YOU REPLY!

Link to comment
Share on other sites

Link to post
Share on other sites

25 minutes ago, _Froyo said:

I know this is a long shot, but I don't know where else to turn.

I was doing some cleaning the other day and found an old phone of mine, an LG L41C. I recall it having some of my files on its internal storage, so I tried to start it up to see if the files were still there. It had been about 3-4 years since I had last used the thing, but last time I did, it worked just fine. However, now it won't turn on or charge. I've tried everything, from cleaning the charging port, to holding volume up / down + power, to even buying a new battery, but nothing gets this thing to budge. I was wondering if anyone here had any ideas to get it to work. Any help would be appreciated.

Most lipo batteries cant stand laying around for more than a ~year at other than 3.8v. You may be able to remove the battery and turn on the phone with the charger attached.

CPU: i7 9700K@5ghz all core (silence + summer)

cache x47, AVX offset 0

Motherboard: Asus Maximus XI Hero

RAM: Patriot Viper Steel 2x8gb@3733mhz @jedec cl15

PSU: EVGA SuperNova 750 G3

Mon:  LG 27GL850-B, 144Hz Nano IPS - G-Sync compatible/Freesync

GPU: EVGA 1080ti SC Black Edition w/ G12 bracket

Sound: Odac + Fiio E09K

Case: Fractal Design R6 TG Blackout

Storage: MP510 960gb and 860 Evo 500gb

Cooling: CPU: Kraken X62 - GPU: Kraken X42(RIP) -> X53 (From RMA)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×