Jump to content

Got 6a, transferred some data from 3a, but incomplete. Local Storage (🎶/📃/📷/etc) fine, but settings, app data, phone #s messed up.

 

attempted TL;DR:  got 6a, some data copied from 3a, but not all.  How to ensure ALL data (including settings, app data, etc) is copied?  Need to factory reset 3a and ship (trade-in) by the 18th.  Some phone numbers messed up in contacts too.  Also have almost decided on case (probably otterbox commuter) but it's a question of finding one in stock quickly enough so I can have it in a day or two, haven't had any luck there.

 

 

Okay so I got the Pixel 6a, and have all but decided on a case for it (most likely Otterbox Commuter, although Spigen Tough Armor is still in the back of my mind).

 

Anyway I need to factory reset the 3a (which is being traded in) and ship it by the 18th, and while I've transferred SOME of the data from my Pixel 3a to the 6a ...

 

Emphasis on some of the data.  Unfortunately, not everything got transferred over properly, especially things that are pretty important to me, and aren't as trivial / easy to transfer as just copying from "internal storage", like music, photos, documents, etc.

 

 

For example, while it did transfer most (idk if all yet?) of my contacts, at least one of them (my sister actually) had the wrong number assigned as the default number on the new phone.  (Both numbers were legitimate at various times / for various purposes, not like it threw in some totally random number, but it just picked the wrong one as default.  I haven't looked at most of my other contacts to determine what might have been screwed up there.

 

Also, while some of my apps themselves got installed, pretty much none of the data got transferred. 
A couple games I had paid for got reverted to their limited trial versions, while I was expecting that one I signed in, that would automatically sync.

Also this is a biggie for me - a lot of the Chrome data didn't transfer properly either.  None of the 4249 chrome tabs in 144 windows got reopened (yes I know that's a lot, but sometimes bookmarks don't work properly for me especially when sites disappear or other things, it's too complicated to go into here), a lot of my settings didn't carry over, and I'm having to re-sign in to various sites that were already signed in on the previous phone.

 

Also, the behavior when closing tabs or switching back to the app is messed up on the 6a.  (While it wasn't perfect on the 3a, it was still better).
On the 3a, if I hit the back button, it would close the tab, and go to the next tab back in the list.  (Except in 2 cases.  1 - the originating tab (from which I did "open in new tab in window" or whatever) was still open in which case it went straight to that tab, OR, that tab was open from a previous session (either through a crash / restart / whatever), in which case it minimized the entire browser.
But, on the 6a, it just minimizes the entire browser.
Also, when I reopen Chrome on the 6a, it brings me to the multi window overview screen, instead of whatever tab I happened to be on.  (Hitting the back button once I get there brings me to that tab, but that's an extra step.)

 


A couple weeks ago I did an adb backup from my Pixel 3a, and also separately copied the entire Internal Storage (via USB cable) from the 3a.

However ... I can tell just from file / folder sizes that it was NOT a complete backup, and I don't know how to do that, or how to restore it to the 6a.
On the Pixel 3a itself, it says the phone is using about 53 GB of storage (or a bit less), with about 11.37 GB free.  (Total is 64GB).

However, the adb backup is only 12.8 GB, while the copied "internal storage" folder is only 15.3 GB.  So, somewhere around 35-40 GB is still missing.  (Yes, I know part of it is the OS, but I'm sure the actual app data, etc, is on there somewhere.)  I just looked in the folder structure, and while there's a com.android.chrome folder in the copied-from-int-storage backup, it's empty.)

 

One thing that might help a little on Chrome is if there's some way I could open the tabs on my desktop computer's Chrome ... but then going on there and looking for tabs from other devices, they don't show up.  (A few of the tabs were, I'll admit, open since within a few weeks or so after I originally GOT the Pixel 6a in September 2019.  Yes, I do close some tabs ... when I'm done with them.)

 

I don't want to root (then unroot) either phone, as I don't want any risk of messing things up, voiding warranty / trade-in, etc.

 

I would have done a bit more in the last week or two, but I've had other things going on, between being at a piano technicians convention for several days the first weekend of August, helping care for my sister's pets (the one whose number got messed up in my phone) while her family is on vacation, dad being in the hospital with a broken femur (and also testing positive for Covid) and other things going on as well.  Anyway I need to get the rest of the stuff transferred from the 3a to the 6a in the next couple days so I can reset the 3a and send it in.

 

 

Anyway, this not having data properly transfer when getting a new device, or reinstalling a new OS, is a perennial issue for me, not just on phones but also on PCs.  I still haven't properly transferred some things from my older PC to my newer one, and a few things I have tried to transfer, like firefox and chrome data by copying the profile folders, it still, among other things, logs me out on one device when I log into the same sites on other devices.  Also my parents recently had their Dell (yeah, I know 😕 ) laptop in the shop cause after we replaced the battery it wouldn't boot, and the shop reinstalled the OS, but failed to preserve the hundreds or thousands of firefox bookmarks my mom had, or the windows logon info / password, or the network printer drivers, and that's just a few things.

Situations like that make me not want to *EVER* reinstall an OS or upgrade to a new platform, until that fatal (to me, at least) flaw (of not transferring everything) is fixed.

 

I think the closest I've seen to having an almost proper "continuation" of OS/settings/apps/etc from one device to another was a time I pulled an M.2 SATA SSD that had Linux installed out of my laptop (with an Intel i7-6700K, Clevo P750DM-G, GTX 970M, 64GB RAM, etc), and plugged it into my current desktop (AMD Ryzen 9 5950X, ASRock B550 Taichi, GTX 1060 3GB, 128GB RAM, etc) and for the most part it was booting and working fine when I tested it several months ago.  (I think there was a little thing it was complaining about but I can't remember at the moment and not really in a position to restart and boot that SSD right now.)

 

To me, a backup isn't just of c:\users\username, which is all the person at the shop did when he "backed up".
To me, a backup is ... if the drive you're backing up is, say, 1 TB, then the BACKUP should take 1 TB of space, regardless of how much space is actually used on the drive being backed up.
A proper backup would copy EVERY bit / sector of the drive, regardless of file system, so that, for example, if you were trying to restore from a situation where a partition got wiped or something, you would have just as much chance of success restoring from a clone as from the original.

Link to comment
Share on other sites

Link to post
Share on other sites

Hmm I'm getting down to the wire, to where I need to factory reset the phone and send it in.  (An email recently reminded me to ship it by the 18th, but I want to send it on the 17th (Today, it's 12:48am as I'm typing) to be a bit on the safe side.

 

I was able to bookmark my Chrome tabs, but it was a painstaking process that took a couple days.  Had to do it one at a time, putting them in folders for each window.  Also some I wasn't properly able to bookmark or save, since the sites / pages no longer exist.

Which reminds me ... I really need a way to be able to pull from local cache AFTER having refreshed from the server in situations like that, any ideas how to do that, so that issue (resource no longer available, or changed) doesn't happen again and I could just use my local cache?

 

Just now I was going through a few apps, and got stuck on Kindle.  There's a couple ebooks in .mobi format on the 3a that aren't in my Kindle library, and I can't open them on the Kindle app on the 6a.

And I realized that a couple apps didn't get transferred at all, with at least one that's installed on the 3a not being available in the Play store at all.
Also for some reason the files didn't properly get transferred when I did the original data transfer, so I had to upload them to Google Drive then re-download on the 6a.  Then, when I tried to open them in the Kindle app, they wouldn't open or preview.

 

I'm sure there's some games I have on there that don't have their progress or settings properly saved either, and my main phone settings also didn't get preserved.

 

 

What can I do to fix this, and make sure everything is properly transferred / synced?  I'd prefer to only use the cloud as a last resort (and would eventually like to set things up so I can be my own private cloud, but that's for another topic / post sometime), and there's no way I can fit 64 GB from the Pixel 3a into my 17GB Google Drive.


Issues like this (and similar issues with PC upgrades / reinstalls, for example my parents' laptop had an issue that, when they took it to the shop, ended up having Windows reinstalled which didn't preserve their user account, firefox bookmarks (a biggie for my mom), wifi access, etc) make me not want to ever buy another computing device until the software makers (or whoever) get their act together and make it so we can completely seamlessly transfer between devices, reinstalls, restarts, etc.


Anyway, I'll have to send the phone in, after a factory reset, later today.  If I had known this would be such a problem (with not all the data/settings/apps/etc being transferred) I would have thought thrice about buying a new phone.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×