Jump to content

Task Manager shows maximum CPU clock speed all the time

TudorF
 Share

Dunno if this is normal. My CPU is i5-11500 which has a base clock speed of 2.7GHz and boost of 4.6GHz. But even at 1% CPU utilization, Task Manager (and other CPU monitoring utilities) show maximum speed on all cores.

I discovered this occasionally without looking for it. I was just checking out something when I noticed this and I'm not sure if it's normal or not.

So I rebooted in a backup system running on an HDD (instead of my main that runs on an NVME drive) and I see somewhat different stats.

 

637616183_Screenshot2022-08-14010410.jpg.8ce8cb32fdc74fc89daadac0d343cd55.jpg

 

Sometimes even lower:

256842379_Screenshot2022-08-14011113.jpg.bfe003c5a010556a7a17277380a875df.jpg

 

But when I boot in the NVME drive, I get this almost all the time:

1833426908_Screenshot2022-08-14011906.jpg.7df9cd08729efe4e1845ea11e86c12a7.jpg

 

Another hardware monitoring utility confirms this:

 

2088110682_Screenshot2022-08-14012038.jpg.1b3aa97f1994caa1b394af347643c169.jpg

 

But when I get in the mobo BIOS I see similarly high CPU clock speeds currently running. So maybe there's no power virus or anything.

Maybe it's some setting that was enabled somewhere.

I checked everything in the BIOS (B560M AORUS ELITE F1) and everything seems to be on Auto settings except for the XMP which was set up when I built the PC.

Is this normal or should I look for some other cause?

From what I know, the boost CPU should only kick into gear when there's a big workload that needs the boost, otherwise the CPU should work on a speed closer to the base one.

Or is this fine? It seems weird to see the CPU at 45 degrees and 1% utilisation, but maximum clock speed.

 

Link to comment
Share on other sites

Link to post
Share on other sites

I solved it by switching the Power profile to Balanced

 

image.png.4d7611b59e3d08835ca448b422a26527.png

 

Then the CPU immediately stopped keeping all cores at maximum clock speed.

Jeez, Windows. Why do you never explain what your settings actually do.

Link to comment
Share on other sites

Link to post
Share on other sites

That didn't solve it, so after doing more testing, it turns out this happens during continuous audio playback, so it might be some driver thing setting that prioritises performance.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×