Jump to content

Razer Blade 15 won't turn on after the recent Windows 11 update.

I've tried a number of things:

  • Checked if the charger is good,
  • Tried different outlets,
  • Held the power button for 15s (only the white LED blinks once),
  • Held the power button, unplugged the charger, and released the button trick,
  • Unplugging the internal battery and just attempt to turn it on using the power brick (no signs of life, no fan, nothing).

The only indication I get from the laptop is the white LED blinks after holding the power button for 10s. That's it. No fans, no display, nothing.
This is a Razer Blade 15 (2018) advanced (GTX 1070 model).

This is the guide I followed in attempts to turn it on: Razer Blade does not have power, won't boot up or turn on.

Any and all help will be appreciated a lot! I have the tools to open it up and inspect as well if I can get guidance on what and where I should look at.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×