Jump to content

RTX 3070 stuttering on UI's

When playing a game normally, the gpu runs perfectly fine, games like The Witcher 3, no stuttering, however when opening the menu (like opening the map), the animations stutter, as if the animations go at a different fps than the entire game.

In some games like Assetto Corsa I can manage to reproduce this, however, the strange thing is that in that game in particular, the animations stutter 1 or 2 times then it gets normal, as if they were loading or smth.

 

This behavior only happens on games, no other software suffers from these issues.

 

Also, not all games suffer from this, Dishonored runs perfectly fine. However, it is an old game so idk.

 

I think it's also worth pointing out that this pc had no gpu for about 6 months now, and so I think (I'm not sure tho) it has both the drivers for the rtx and for the integrated graphics. Idk if that might cause issues. I think this explains why I see 2 GPU's in the task manager.

 

I don't have a clue what might be causing it, and I'm on a warraty policy, so, should I claim the warranty or is it a driver issue?

 

My setup is:

- i9 12900k

- RTX 3070

- PS: 850w
- RAM: 48bg ddr4 @ 2133 MHz

- HDD: nvme 1 Tb @ ~7 Gb/s

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×