Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How do I Stop Browser Redirects from Happening for Good?

I'm having an issue where the Kia website automatically redirects me to the Panamanian version of the site.

 

I've also had issues in the past with match.com redirecting to the UK version of that site and HBOMax redirecting to the Polish version of that site. 

 

In the latter cases, both of the issues went away after browser updates.

 

However, this is happening again, this time with Kia (and the Jeep website was asking me if I wanted to go to the Panamanian version of that site but allowed me to go to the US version).

 


How do I stop this for good? 

 

I am in the US. I use Express VPN but that's always usually set to a US location  and I've used it without issues before the past few months.

 

This issue also seems to be happening on all my browsers (Opera, Firefox, etc.) and not just on Chrome.

 

I've tried clearing my cache and cookies and that hasn't fixed it nor has uninstalling Express VPN when I tried that in the past.

 

I've also ran malware/virus scans with Windows Defender and no viruses or anything like that has shown up through that.

 

How on Earth do I stop this?!

Link to comment
Share on other sites

Link to post
Share on other sites

Could try using noscript to disable javascript. But it's likely based on your IP... So if you use a VPN... Expect to be sent away. Though I'm surprised it still sends you away even with a US server

CPU: AMD Ryzen 3600 / GPU: Radeon HD7970 GHz 3GB with Noctua Fans / RAM: Corsair Vengeance LPX 2x8GB DDR4-3200
MOBO: MSI B450m Gaming Plus / NVME: Corsair MP510 240GB / Case: TT Core v21 / PSU: Seasonic 750W / OS: Win 10 Pro

Link to comment
Share on other sites

Link to post
Share on other sites

Check what whatismyip says about your location, see if that matches what the website sends you to.

So try not to use the VPN, and maybe clear all cookies from those website before trying to use them again since they'll likely store the location for next time you visit.

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB SX8200Pro, 2x16TB Ironwolf RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary, Mountain Everest Max

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB SX8200Pro RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Asus Zenbook UM325UA, Ryzen 7 5700u, 16GB, 1TB, OLED

 

GPD Win 2

Link to comment
Share on other sites

Link to post
Share on other sites

24 minutes ago, Kilrah said:

Check what whatismyip says about your location, see if that matches what the website sends you to.

So try not to use the VPN, and maybe clear all cookies from those website before trying to use them again since they'll likely store the location for next time you visit.

Whatismyip says my location is where I'm actually at - Iowa, USA

 

Issue still happens even if my VPN is off

Link to comment
Share on other sites

Link to post
Share on other sites

It is hard to pinpoint exactly why and how this happens because there are multiple ways a web developer might implement this.

Some implements it by using the browser's "accept-language" flag. You can see which languages your browser presents using this website. For example mine says English at quality 1 and Swedish at quality 0.9. This means that if the web developer has implemented redirects based on this, it will primarily direct me to an English language website, and use a Swedish language website as a backup. A higher quality number is prefered.

 

The browser's accept-language header is configured by the browser. In Chrome, it is configured under the advanced section under "Language and Input Settings" (LINK). The higher something is in the list, the higher the quality setting will be.

 

 

I am not a web developer so I don't know how common this is, but another method I can think of would be to use anycast or DNS to redirect traffic based on region. If this is the case, then changing your DNS to one hosted in the country you want to appear in might help. For example don't use a DNS hosted in the US if you are on Polen and want to visit polish websites. In fact, this is just good advice in general since accessing far away DNSes might make the initial connection to a website needlessly slow.

 

 

The third method I can think of is probably the most common one. Looking up the IP address, matching it against a region, and then redirecting based on that. If this is how websites handle this, and I suspect they do, then you are kind of screwed. 

Chrome has a feature for blocking redirects (can be found HERE) but I doubt it actually works. You might just have to block all JavaScript to deal with this, but chances are that will break way more than it fixes.

Link to comment
Share on other sites

Link to post
Share on other sites

Switch to Brave

Been to some less than reputable sites with lots of pop-ups using it and I haven't seen one since I started using it

 

That and I think Chrome has a way to disable scripts in the settings

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×