Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Weird keyboard problems

Go to solution Solved by Juliasmatius,
15 hours ago, Visler7000 said:

I suspect it to be Mobo related somehow i have cleaned the PC and to my eyes i can't se anything wrong, clean install and bios flash should have done something, so now I'm thinking hardware problem?

yea but one thing is that you could try a pci usb card them change the mobo if that doesnt work vhange the cpu

My brothers PC has this thing where only a few keys are working on he's PC it's ah 4 years old gaming rig.

 

What i have done so far:

Reinstalling all USB drivers 

New Windows 10 install 

Bios update

New keyboard 

Running Windows troubleshooter 

Updating everything 

Also keyboard wont work in safe mode

 

Specs i5 6500 

Mobo Asus h110-a

Gtx960

240gb SSD

1000gb HDD 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Juliasmatius said:

what keyboard is it?

We have a razor chroma and a Chinese no name one both has exactly the same symptoms all numbers work and g,b,n keys 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Visler7000 said:

We have a razor chroma and a Chinese no name one both has exactly the same symptoms all numbers work and g,b,n keys 

open hardware info and go to the hid deviced look if there are any problems

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Juliasmatius said:

open hardware info and go to the hid deviced look if there are any problems

Nothing also just tryed removing it and let it search for it again, problems still there

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Juliasmatius said:

try changing to front panel usb

It's the same 

Link to comment
Share on other sites

Link to post
Share on other sites

I suspect it to be Mobo related somehow i have cleaned the PC and to my eyes i can't se anything wrong, clean install and bios flash should have done something, so now I'm thinking hardware problem?

Link to comment
Share on other sites

Link to post
Share on other sites

15 hours ago, Visler7000 said:

I suspect it to be Mobo related somehow i have cleaned the PC and to my eyes i can't se anything wrong, clean install and bios flash should have done something, so now I'm thinking hardware problem?

yea but one thing is that you could try a pci usb card them change the mobo if that doesnt work vhange the cpu

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Juliasmatius said:

yea but one thing is that you could try a pci usb card them change the mobo if that doesnt work vhange the cpu

Thanks i looked true my old junk and i have usb for PCI, i found the problem and it's really a weird one, in he's PCI slot there is a wifi card i removed it, checked if the PC will take keyboards, and yes it will in all ports and any keyboard. Thanks for leading me to the solution.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×