Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Installed latest drivers, now screens go black and won't come back on

I just installed the latest NVIDIA drivers and now my computer quite frequently goes black when idle and the screens will never wake up, even if the computer is running.  Power cycling the monitors won't work.  The only thing that works is hard rebooting the PC.  I'm sporting an RTX 3090.  Anyone else getting this, or have any ideas what the issue could be?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Shimejii said:

Id suggest you just dont let the screens go black on idle. turn off power savings, and then try turning off the monitor and turning it back on. From that point, youll probably have to get use to doing that until they fix the driver 🙂

That would be the simplest workaround. 😄  Just hoping someone knows of something more proper that would let me monitors go to sleep, since I think the Samsung Odyssey G9 does need quite a bit of power when awake, and I WILL forget to turn them off, lol.

Link to comment
Share on other sites

Link to post
Share on other sites

28 minutes ago, Cyberpower678 said:

That would be the simplest workaround. 😄  Just hoping someone knows of something more proper that would let me monitors go to sleep, since I think the Samsung Odyssey G9 does need quite a bit of power when awake, and I WILL forget to turn them off, lol.

from a samsung g9 post 

 

Ok so I went ahead and reset the monitor to default settings and it worked. So to troubleshoot I put the Picture back on Dynamic Contrast which was my previous selection and put the computer back to sleep. Had the same issue, with the monitor not detecting the display. Unplugged the DP and replugged it in and it came back. Reset the monitor to the default Custom picture and have had no issues. 

 

There seems to be some problem with the monitor coming back to my DP input when the Picture setting is Dynamic Contrast (I have not gone through any of the other Picture settings yet to test). 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

31 minutes ago, Shimejii said:

from a samsung g9 post 

 

Ok so I went ahead and reset the monitor to default settings and it worked. So to troubleshoot I put the Picture back on Dynamic Contrast which was my previous selection and put the computer back to sleep. Had the same issue, with the monitor not detecting the display. Unplugged the DP and replugged it in and it came back. Reset the monitor to the default Custom picture and have had no issues. 

 

There seems to be some problem with the monitor coming back to my DP input when the Picture setting is Dynamic Contrast (I have not gone through any of the other Picture settings yet to test). 

 

 

Thanks for that, but I'm running a dual monitor setup and the second one is a Dell 4K connected via HDMI, and that doesn't wake up either. 😞

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×