Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

CPU Cooler Fan & Graphics Card does not turn on

Beemoh
 Share

I've recently started to build a new PC with the following parts:

  • Motherboard: ASUS Prime x570-Pro
  • CPU: Ryzen 7 5800X
  • CPU Cooler: Hyper 212 RGB Black Edition
  • GPU: Nvidia RTX 3060
  • RAM: Corsair Dominator Platinum RGB 4x8GB
  • PSU: Silverstone Technology SX1000 1000W 80+ Platinum

However, when I turned on the motherboard, it would not power on the GPU and CPU Cooler.

 

I have repeatedly turned it on and off and only ever saw my RAM light up with RGB. I have also tried switching the CPU with the AMD Ryzen 5 3600 to see if it was just a BIOS update, but it still would not turn on. I also re-plugged in everything, but to no avail. All troubleshooting attempts only had the CPU, GPU, and 1 RAM stick plugged in as well.

 

What could be the issue here?

Link to comment
Share on other sites

Link to post
Share on other sites

Do you have a boot drive connected?

 

Spoiler

I am not ShrimpBrime. ok yes I am.

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, Guest 5150 said:

Do you have a boot drive connected?

No I do not

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, Beemoh said:

No I do not

That board won't post unless there's a boot drive connected. Use the windows installation media.

 

Clear cmos before hand. Read the manual for how to.

 

Spoiler

I am not ShrimpBrime. ok yes I am.

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Guest 5150 said:

That board won't post unless there's a boot drive connected. Use the windows installation media.

 

Clear cmos before hand. Read the manual for how to.

Tried that and that did not work.

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, Beemoh said:

Tried that and that did not work.

Does the board have flash back? 

 

Spoiler

I am not ShrimpBrime. ok yes I am.

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, Guest 5150 said:

Does the board have flash back? 

No, it does not.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×