Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Motherboard bios is bad and i have no idea what to do

So i had got a Aorus z490 master from a family member that had corrupted the bios, so i had tried to flash it externally with the ch341a, but i encountered a problem, the program that the clip uses doesn't support the bios chip.

so I'm out of ideas. (i cant find any bios flashback button)

Any help?

 

Link to comment
Share on other sites

Link to post
Share on other sites

Unfortunately this mobo does not have flashback button , only way is to flash externally with with a flasher 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Linus5exT1ps said:

Unfortunately this mobo does not have flashback button , only way is to flash externally with with a flasher 

i've tried an external flasher but it doesn't support the chip so i don't know 

Link to comment
Share on other sites

Link to post
Share on other sites

Posted (edited)

I did a search and found this... perhaps this is a common problem with updates? Unfortunately the referenced forum no longer exists or has been moved. Also shows something about certain M.2 incompatibilities. Another possible factor that could have caused the corruption?

 

image.png.161dd152ed657b3b042d108b80b5ea2c.png

Edited by An0maly_76
Revised, more info

OP: My PC cuts off and crashes. Is the 1000W PSU enough?  ME: 1000W is plenty, PSU or system board could be faulty. Get both tested.

OP: I don't think so, both parts were purchased last week.        😒  Why bother asking if you second-guess the advice?

Friends don't let friends use Apple.                                              NOTE: Recently diagnosed autistic. I don't intend to ruffle anyone's feathers.

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, An0maly_76 said:

I did a search and found this... perhaps this is a common problem with updates? Unfortunately the referenced forum no longer exists or has been moved. Also shows something about certain M.2 incompatibilities. Another possible factor that could have caused the corruption?

 

image.png.161dd152ed657b3b042d108b80b5ea2c.png

hey thanks so the story is that the family tried to build a hackintosh but faild so they gave it to me so i can build a pc but both the main bios and the backup bios is bad so i tried 

with the ch341a but it didint work, and i dont have any sorage media installed.

Link to comment
Share on other sites

Link to post
Share on other sites

This mobo comes with dual bios , of you are good with soldering , you can try to switch the bios chips , see if that will help 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Linus5exT1ps said:

This mobo comes with dual bios , of you are good with soldering , you can try to switch the bios chips , see if that will help 

but the backup bios is also bad

Link to comment
Share on other sites

Link to post
Share on other sites

22 minutes ago, The8BitGabe said:

but the backup bios is also bad

How do you know that Bios is the issue ? 

Link to comment
Share on other sites

Link to post
Share on other sites

Then which is cheaper, non-warranty repair, or a new board?

OP: My PC cuts off and crashes. Is the 1000W PSU enough?  ME: 1000W is plenty, PSU or system board could be faulty. Get both tested.

OP: I don't think so, both parts were purchased last week.        😒  Why bother asking if you second-guess the advice?

Friends don't let friends use Apple.                                              NOTE: Recently diagnosed autistic. I don't intend to ruffle anyone's feathers.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, An0maly_76 said:

Then which is cheaper, non-warranty repair, or a new board?

if the problem is the chips for 100% they cost 15$ each , but you must be sure that chips are damaged, 

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, An0maly_76 said:

Then which is cheaper, non-warranty repair, or a new board?

new board sadly

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, Linus5exT1ps said:

if the problem is the chips for 100% they cost 15$ each , but you must be sure that chips are damaged, 

il check if they are

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×