Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Gigabyte B660M Skips BIOS, Can't Set Boot Priority

In short, I've spent most of today troubleshooting the Gigabyte B660M DS3H AX motherboard. The motherboard seems to boot correctly, but no splash screens appear, and hitting any of the BIOS/Boot Order buttons on the keyboard gets no response.

 

The odd thing is - I'd normally think this means the motherboard hasn't passed its POST, so I went about re-seating components and checking my cabling to no avail. When that didn't work, just out of curiosity, I put in an Ubuntu install USB, and it booted to the Ubuntu installer perfectly, except it still skipped the BIOS, so I could not change boot priority at any point. I have three of these motherboards, and all of them behave the exact same way. Ubuntu working would be great and all, except these machines need to run specific software at my workplace, available only on Windows, and none of the four Windows USB install drives I have show anything. What are the odds I've ended up with 3 dud motherboards?

 

The setup I was using is;

CPU: Intel i5 12400F (stock cooler)
MB: Gigabyte B660M DS3H AX (3 of them, same behaviour)

RAM: Corsair Vengeance LPX CMK16GX4M2A2400C16 16GB (2x8GB)

GPU: Sapphire AMD R5 230 (also tried an old AMD HD7850 I had lying around the office)

PSU: Corsair CX650M 650W

M.2: Kingston NV1 1TB

 

I do not know the BIOS version, because I can't get to it!

 

I have tried all of the following on each motherboard;

  • Holding and mashing F2, Delete, F12 and End while booting
  • Using the keyboard in every USB port available (don't have a PS2 cable around unfortunately)
  • Clearing CMOS (several times, with jumpers, removing the battery, and holding power/reset)
  • Booting with no drives plugged into the machine
  • Booting with a blank M.2 SSD in the machine
  • Booting with an Ubuntu Install USB (installations made to the system SSD this way also work)
  • Booting with a Windows Install USB
  • Plugging in installation media both before and after the machine is powered on
  • using 'sudo systemctl reboot --firmware-setup' from Ubuntu to get to BIOS (just goes straight back to Ubuntu)

Looking online, all resources to fix Gigabyte skipping BIOS seem to be for existing installations, and are mostly related to fast-boot settings. Gigabyte's tool to disable fast-boot is Windows only.

 

I do have a few plans to continue this troubleshooting when I'm next back in the office, but I figured since I'd set up this thread for anyone who may run into the same issue, since none of the threads I'd come across had got me across the line.

 

Yet to try:

Link to comment
Share on other sites

Link to post
Share on other sites

Could be interesting to see if flashing to the most recent bios changes anything (with the Qflash / no cpu needed flashback functionality)

 

Are you sure the Windows USB's are UEFI bootable?

 

I'd install Windows on another pc, transplant the ssd to boot into windows on the b660 and go in the bios from there (shift click on restart -> troubleshooting -> boot to uefi). Then turn off fast boot.

 

Very strange though! I've had this problem but not on any recent boards.

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Sjaakie said:

Are you sure the Windows USB's are UEFI bootable?

 

I'd install Windows on another pc, transplant the ssd to boot into windows on the b660 and go in the bios from there (shift click on restart -> troubleshooting -> boot to uefi). Then turn off fast boot.

I'm fairly certain the Windows USBs are UEFI compatible. I have some that came from Microsoft, that I got with the license keys for these machines, and one I made myself. The one I made myself definitely worked on another machine at the office.

 

Unfortunately most of the working computers around the office are proprietary boxes, which will make creating a boot SSD elsewhere a hassle, but I'll update as I go!

Link to comment
Share on other sites

Link to post
Share on other sites

Hey there, today's update on this - good news is I've managed to get one of the three systems working, and haven't had a chance to build the others.

 

Flashing to the latest updated F6b BIOS did not resolve the issue, nor did changing EFI BIOS settings from Linux. Everything would spit me straight past the BIOS. Unfortunately, I do have to report that it was changing the CPU to an i5 12400 (as in, integrated graphics, no dedicated GPU), worked immediately. Hopefully this is simply a compatibility issue with the generation of AMD GPUs that I have (all 2015 or older), so most people won't run in to the issue at all.

 

Unfortunately - if you are running in to the problem and don't have the option to use integrated graphics, this may not be the thread you're looking for. I'm lucky that integrated graphics was the intended setup for these machines, and simply a communication problem had put the wrong CPU on my order.

 

I didn't get the time to try another Linux distro, since that was more for my own curiosity than actual troubleshooting. I was also unable to figure out how to disable fast boot from within Ubuntu. I didn't try installing Windows via a different machine, since logistically I could only do that after trying the iGPU. If I can, I might try still these on one of the remaining two machines I've yet to finish building.

 

I'll keep this thread as unresolved until I've got all three machines working, since on paper the GPUs I tried should be compatible? Maybe I'm missing something in the documentation though.

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, Cardica said:

Hey there, today's update on this - good news is I've managed to get one of the three systems working, and haven't had a chance to build the others.

 

Flashing to the latest updated F6b BIOS did not resolve the issue, nor did changing EFI BIOS settings from Linux. Everything would spit me straight past the BIOS. Unfortunately, I do have to report that it was changing the CPU to an i5 12400 (as in, integrated graphics, no dedicated GPU), worked immediately. Hopefully this is simply a compatibility issue with the generation of AMD GPUs that I have (all 2015 or older), so most people won't run in to the issue at all.

 

Unfortunately - if you are running in to the problem and don't have the option to use integrated graphics, this may not be the thread you're looking for. I'm lucky that integrated graphics was the intended setup for these machines, and simply a communication problem had put the wrong CPU on my order.

 

I didn't get the time to try another Linux distro, since that was more for my own curiosity than actual troubleshooting. I was also unable to figure out how to disable fast boot from within Ubuntu. I didn't try installing Windows via a different machine, since logistically I could only do that after trying the iGPU. If I can, I might try still these on one of the remaining two machines I've yet to finish building.

 

I'll keep this thread as unresolved until I've got all three machines working, since on paper the GPUs I tried should be compatible? Maybe I'm missing something in the documentation though.

Maybe it conflicted with CSM setting in BIOS ?

There is approximately 99% chance I edited my post

Refresh before you reply

__________________________________________

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×