Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Weird HDD and Enclosures Compatibility

Wfz234
 Share

So, I have old 5 years HGST 500 GB 2.5" HDD AND new WD Blue 1TB 2.5". For the enclosures, I have ADATA ED600,  Orico 257u3, and Ugreen.

 

My desktop specification is:

  • Core i5 10400
  • RAM PNY 2x8 GB
  • ASUS GTX 1050 Ti
  • ASUS TUF Gaming B560M Plus
  • Be Quiet! 500W

The problem is, the only enclosure and HDD combination that can works well without problem is Ugreen + WD Blue 1TB. If I change the combination, like: Ugreen+HGST, ADATA+WD, ADATA+HGST, etc, problem always happen.

 

BUT, this only happen in my desktop, not with my laptop. It doesnt matter what combination I use, they can works well in my laptop

 

To show what I mean, you can see picture: [MEDIA=imgur]a/qIZIh4j[/MEDIA]

View: https://imgur.com/a/qIZIh4j

 

 

disconnect means: all usb device (mouse, wifi usb, enclosure, keyboard, etc) disconnected for few seconds then reconnect again

 

freeze means: the drive stuck/hang, cant do anything, cant eject until I unplug the enclosure

 

stuck sec means: it hang/freeze only for few seconds then back to normal, no impact at all.

 

Question is: how to fix this problem in my desktop? 

 

What I have done is: 

disable usb power saving in device manager and power setting

update usb driver

disable then reenable usb in device manager

update windows

 

But no one of them work for me.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×