Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Ctrl on my Tecware Phantom L keyboard pressing multiple keys at the same time

Posted (edited)

So far, ive tried uninstalling my keyboard from the device manager and restarting, trying to rebind the control key, and cleaning my keyboard, but it still presses multiple keys at the same time when I try to press it. Also, the 2 light indicators on the top of my keyboard blink on and off for a short while after I press the ctrl key, which is supposed to indicate when caps lock and scroll lock is on, but I'm not sure if it means something if they both flash on and off. Ive also noticed my right ctrl works perfectly fine, but when i try to bind right ctrl to left ctrl, nothing changes.

Edit: I solved the problem. I swapped the right ctrl and left ctrl switches, and now left ctrl works. Now, what confuses me is that the right ctrl works too. Aint gonna complain tho, but im curious what the heck couldve happened

Edited by Boriiiiiiiiis
Wanted to add on what ive tried
Link to comment
Share on other sites

Link to post
Share on other sites

I have a tecware phantom tkl and it sometimes does the same thing. Overall it is a solid keyboard. I swapped my switches a while back as well, but now my right ctrl doesnt work, but who uses that amiright?

Specs: 11700 | RTX 3060 | 32gb 3200mhz | 1tb 970 + 2TB HDD | Lian Li O11D Mini X Black

I'm 15 and live in the US

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×