Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Fixed: ASUS ROG Strix X570-I Gaming Mobo operates fine until you install Graphics Drivers then Black Screen

 Share

The Problem:

Fresh instillation of windows goes without a hitch, installed all the updates before attempting installing graphics drivers. Graphics Driver instillation gets about 1/3rd of the way through instillation before screen goes black and monitor goes to sleep and does not recover (Gave it 2 hours). Cycling the computer greets user with a black screen upon boot, and two more cycles you see bios, and then windows attempts load before freezing and black screening. After two attempts windows repair tool is prompted and attempting repair results in windows install in a unrecoverable state and the only way to proceed forward is to format and re-install a fresh instillation of windows.

 

The Build:
OS: Windows 10 PRO 64 Bit
Mobo: ASUS ROG Strix X570-I Gaming Mini ITX
Processor: AMD - Ryzen 7 5800X 4th Gen 8-core, 16-threads Unlocked Desktop
Ram: Corsair Vengeance LPX 32GB (2 X 16GB) DDR4 3600 (PC4-28800) C18 1.35V
Drives: 2x SAMSUNG 970 EVO Plus SSD 1TB

Graphics Card: NVIDIA - GeForce RTX 3090 Ti Founders Edition
PSU: CORSAIR - SF Series 750W ATX12V ( I am aware this is bellow the recommended power please read what has been tried )

 

What has been tried:

Trippel check connections 

Attached PSU rated for 1000W

Preformed multiple clean installs of Windows 10 and 11 pro 64x Bit using media client off Microsoft website. 

Flashed Bios and updated to pre beta build after trying beta build of Bios.

Swapped graphics card out with a GeForce RTX 3070 Founders Edition, and a GTX 1660 no effect

Cards operate fine if swapped into another rig (Was lucky enough to have a friend with a big enough case to test this and a spare graphics cards.)

Used GPU Guru to try and do a clean install of drivers in safe mode with older version after fresh version of Nvidia drivers failed with same results.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Hi,

I hade the same problem by my 1070, I only needed to update my bios, that did work.

Hope this helps!

Link to comment
Share on other sites

Link to post
Share on other sites

Suspect It might be Mobo, replaced with new mobo and everything worked fine.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×