Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Onkyo TX-SR313 no TrueHD or DTS-HD from Windows

Ghajik
 Share

I have read that in windows you need atleast 8 channels to send hd audio formats despite the receiver able to decode the formats. The SR313 is a 5.1 receiver so how do i trick windows into thinking that its a 8 channel device?

 

Someone with same issue but the solution seems to be outdated : https://forum.kodi.tv/showthread.php?tid=205490

Link to comment
Share on other sites

Link to post
Share on other sites

What you can try is editing EDID using CRU. I don't have 5.1 receiver to test so I can't confirm whether it'll work, but I was able to dumb my receiver down from 7.1 to 5.1. 

 

Upon opening CRU select your AVR then select CTA-861 on one of extension blocks and click Edit. On audio formats click edit and try adding ones that support 8 channels (e.g. DTS-HD, Dolby True HD, EAC3, LPCM). Then edit speaker setup and click 7.1 at the bottom.

 

Restart your PC and hope it'll work out. 

CPU: RYZEN 9 5950X | GPU: SAPPHIRE NITRO+ AMD RADEON 6800XT | MB: MSI MAG X570 TOMAHAWK | RAM: G.SKILL TRIDENT Z NEO 32GB (2x16GB) DDR4-3600 | COOLING: NOCTUA NH-D15, CORSAIR ML120 & ML140 | CASE: IN-WIN 707 | 5.25" BAY: LG WH16NS60 INTERNAL BLU-RAY OPTICAL DRIVE | KEYBOARD: CORSAIR K95 PLATINUM XT BROWN SWITCH | MOUSE: LOGITECH G903 HERO | CONTROLLER: PDP AFTERGLOW WIRED CONTROLLER | PSU: SEASONIC PRIME PLATINUM 1000W | UPS: POWERSHIELD COMMANDER TOWER 1100VA | DISPLAYS: LG 34GN850, 2x DELL S2719DGF (portrait) | TV: LG C1 48" | AMPLIFIER: MARANTZ SR7013, YAMAHA AS-501 | SPEAKERS: DALI ZENSOR 5 & DALI ZENSOR VOKAL & JAMO A310 SATELLITE & 2x SVS-SB2000 | HEADPHONE DAC+AMP: TOPPING L30+E30 | HEADPHONE: SENNHEISER HD6XX | MICROPHONE: AUDIO-TECHNICA AT9934USB | BLU-RAY PLAYER: PANASONIC UB820

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, BuzzingBee said:

What you can try is editing EDID using CRU. I don't have 5.1 receiver to test so I can't confirm whether it'll work, but I was able to dumb my receiver down from 7.1 to 5.1. 

 

Upon opening CRU select your AVR then select CTA-861 on one of extension blocks and click Edit. On audio formats click edit and try adding ones that support 8 channels (e.g. DTS-HD, Dolby True HD, EAC3, LPCM). Then edit speaker setup and click 7.1 at the bottom.

 

Restart your PC and hope it'll work out. 

THANK YOU SO MUCH, it works and it is putting tears in my eyes. The amount of time i've wasted on this thing, and i almost gave up. Thank you and yes it works.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×