Jump to content

Give a Warning Pop-up Before Setting Text to Black

SorryClaire
 Share

I have seen some flareups of people not using automatic colors and straight going for black color for text, making it ineligible for anyone on dark mode. I dont know why this isnt an Envision default already but is it possible to make a warning popup for users before setting text to black? Something like:

 

"Wait!"
"Keeping your text color to Automatic will keep your text readable for users in dark mode, are you sure you want to continue?"

Remember to press quote to get a response from someone! | Check people's edited comments! | Be specific! Our answer effort is in proportion of your effort to write it! | React to your heart, not peer pressure!

 

"Wow, you want me to say ara ara? Really?"

- Clock Girl

Self Introduction and Current Rig

 

🏳️⚧️ Rights

Link to comment
Share on other sites

Link to post
Share on other sites

Part of the problem is the editor's default to pasting in rich-text, so likely any post with black font is pasting from a source that had black font color to begin with (i.e. I don't think they're manually setting it).

 

Perhaps a linter that runs after "submit" is fired but before actually posting that can generate the pop-up, checking for any text set to black/dark blue/etc.?

Main System (Byarlant): Ryzen 7 3800XT | Asus B350-F Strix | EK 240mm Basic AIO | 16GB G.Skill DDR4 3200MT/s CAS-14 | PNY RTX 3060 Ti XLR8 Gaming Revel Epic-X | Samsung 960 PRO 512GB / Samsung 970 EVO 500GB / Crucial MX500 2TB / Crucial MX500 500GB / WD White 7200RPM 8TB | Corsair RM750X | Mellanox ConnectX-3 10G NIC | Hyte Y60 Case | Dell U3415W Monitor | Microsoft Modern Keyboard

 

Laptop (Narrative): Lenovo Flex 5 81X20005US | Ryzen 5 4500U | 16GB RAM (soldered) | Vega 6 Graphics | SKHynix P31 1TB NVMe SSD | Intel AX200 Wifi (all-around awesome machine)

 

TrueNAS Server (Veda): Xeon E3-1241v3 | Supermicro X10SLL-F | Corsair H60 | 32GB Micron DDR3L ECC 1600MHz | 4x 10TB WD Whites / 4x 14TB Seagate Exos / 2x 1TB HGST 2.5" / 2x Samsung PM963a 960GB SSD / 1x Kingston 16GB SSD | Seasonic Prime Fanless 500W | Mellanox ConnectX-3 10G NIC | LSI 9207-8i LBA | Fractal Design Node 804 Case (side panels swapped to show off drives)


Media Center/Video Capture (Jesta Cannon): Ryzen 5 1600X | ASRock B450M Pro4 R2.0 | Noctua NH-L12S | 16GB Crucial DDR4 3200MT/s CAS-22 | EVGA GTX750Ti SC | UMIS NVMe SSD 256GB / Seagate 1.5TB HDD | Corsair CX450M | Hauppauge ImpactVCB-PCIe | Mellanox ConnectX-2 10G NIC | LG UH12NS30 BD-ROM | Silverstone Sugo SG-11 Case

 

Camera: Sony ɑ7II (w/ Meike Grip) | Sony SEL24240 | Samyang 35mm ƒ/2.8 | Sony SEL50F18F | Sony SEL2870 (kit lens) | PNY Elite Perfomance SDXC cards

 

Network: Google Fiber Webpass (500/500) > Unifi Security Gateway (Office) > Unifi Flex-XG + Unifi Switch 8 60W (Office) > Unifi Flex-XG (Closet) > Unifi Flex-XG (Bedroom) + Unifi Switch 8 (Media Center) > Unifi UAP-nanoHD


Tablet (---): Samsung Galaxy Tab A 8"
 

Spoiler

Laptop (Rozen-Zulu): Sony VAIO VPCF13WFX | Core i7-740QM | 8GB Patriot DDR3 | GT 425M | Kingston 120GB SSD | Blu-ray Drive | Intel 7260 Wifi (lived a good life, retired with honor)


Tablet (ReGZ): Asus T102HA (BIOS clock doesn't tick, loses time when sleep/off) (I kill tablets with disturbing regularity)

Tablet (Unicorn): Surface Pro 2 (battery will reset total capacity to current charge, leading Windows to think it's always 100% charged until it dies)

Tablet (Loto): Dell Venue 8 Pro (screen discoloration issues, wouldn't update to Windows 10)

Tablet: iPad 2 16GB (WiFi died, basically useless after that)

Testbed/Old Desktop (Kshatriya): Xeon X5470 @ 4.0GHz | ZALMAN CNPS9500 | Gigabyte EP45-UD3L | 8GB Nanya DDR2 400MHz | XFX HD6870 DD | OCZ Vertex 3 Max-IOPS 120GB | Corsair CX430M (?) | HooToo USB 3.0 PCIe Card | NZXT H230 Case (mostly intact, but some parts have been scavenged)

 

Parts: XFX RX 5600 XT THICC II

Link to comment
Share on other sites

Link to post
Share on other sites

I've personally never seen a post on here with black text. What I have seen is posts where the font suddenly goes like this.

It's weird. It's probably pebcak. You can't protect users against their own ignorance every time.

 

In this case, I agree though that a warning or banner of some kind would be a good idea.

Link to comment
Share on other sites

Link to post
Share on other sites

This actually happens both ways - though admittedly far more often with Black text and someone in Dark Mode - but occasionally you'll see someone in Dark Mode create a post with White Text (instead of automatic) which makes it illegible for Light Mode users.

 

It's a problem in both cases - a popup would be good, but I agree with @AbydosOne in that the fact that the editor defaults to pasting Rich Text likely complicates this even further.

For Sale: Meraki Bundle

 

iPhone Xr 128 GB Product Red - HP Spectre x360 13" (i5 - 8 GB RAM - 256 GB SSD) - HP ZBook 15v G5 15" (i7-8850H - 16 GB RAM - 512 GB SSD - NVIDIA Quadro P600)

 

Link to comment
Share on other sites

Link to post
Share on other sites

There's already warning when pasting rich text (aka text with existing formatting). Similar warning exist when replying to old threads, not that that actually helps anything....

 

If someone chooses to use black text while writing, not pasting, they know what they are doing. Which would either mean to troll or to effect.

 

Pure black is still visible on Night Theme. To make it actually invisible, they would need to specifically use background color. And that one falls down to trolling and is against CS.

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×