Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How to set RAM profile in BIOS?

Hello,

I recently tried using the XMP profile on my motherboard to boost the ram to the correct speed and have seen a serious FPS boost. However, now I seem to be getting BSOD on boot up. This happened a long time ago when I first built the machine so I decided to turn it off to try again later. Now, that time is later. The XMP profile works for boosting the ram and increasing performance, but the BSOD still happens occasionally on start up.

What information do I need to manually enter the overclock for the RAM to eliminate any problems with the XMP button doing the wrong thing?

Please explain like I'm 5 as I have absolutely no idea what I should be doing.

Link to comment
Share on other sites

Link to post
Share on other sites

If the RAM is causing the blue screen, then either the memory controller on the CPU or the RAM itself cannot handle the XMP memory timings and/or speed.

 

The first thing I would try is lowering the memory speed by one level. So, enable XMP, then go to the memory overclocking settings and manually drop the speed. So if your memory is DDR4-3600, lower it to 3466 speed, or whatever the next step down is in your BIOS settings.

 

The reason to do it this way is that you'll still get the better timings from XMP, which are more complicated, but hopefully it will make the memory just slow enough to be stable without massively hurting performance.

 

Hopefully that works, but if not, you can repeat the process until you get a stable speed. Then, we can try to figure out if you should also tighten up the timings.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, YoungBlade said:

If the RAM is causing the blue screen, then either the memory controller on the CPU or the RAM itself cannot handle the XMP memory timings and/or speed.

 

The first thing I would try is lowering the memory speed by one level. So, enable XMP, then go to the memory overclocking settings and manually drop the speed. So if your memory is DDR4-3600, lower it to 3466 speed, or whatever the next step down is in your BIOS settings.

 

The reason to do it this way is that you'll still get the better timings from XMP, which are more complicated, but hopefully it will make the memory just slow enough to be stable without massively hurting performance.

 

Hopefully that works, but if not, you can repeat the process until you get a stable speed. Then, we can try to figure out if you should also tighten up the timings.

Okay, I'll give that a go later when I'm free.

Would it help to post specs on here for the Ram and Mobo?

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, Katnip said:

Okay, I'll give that a go later when I'm free.

Would it help to post specs on here for the Ram and Mobo?

That would be nice to know so we can see if this behavior is expected and what might be the root cause. For example, Ryzen CPUs typically struggle with higher memory speeds, and motherboards with 4 slots have a harder time with overly tight timings.

Link to comment
Share on other sites

Link to post
Share on other sites

Just tried the step down that you described above and done a few shut downs and power ons and things seem to be working fine - went from 3200 to 3133. Hopefully that has fixed the issue. If it has, thank you very muchly.

Just incase, however, here's the specs of the system:

RAM: https://uk.pcpartpicker.com/product/QDhKHx/corsair-vengeance-rgb-pro-16gb-2-x-8gb-ddr4-3200-memory-cmw16gx4m2c3200c16

Motherboard: https://uk.pcpartpicker.com/product/gwPgXL/msi-mpg-x570-gaming-edge-wifi-atx-am4-motherboard-mpg-x570-gaming-edge-wifi

CPU: https://uk.pcpartpicker.com/product/3WYLrH/amd-ryzen-5-3600x-38-ghz-6-core-processor-100-100000022box

Link to comment
Share on other sites

Link to post
Share on other sites

Well... we would need to know how many sticks you are trying to run. Are they all from the same kit?

 

Also what can happen is that XMP doesn't always load all the timings. In which case they have to be loaded manually. In Asus BIOS I have a page called SPD where I can see what timings are supposed to be in use, maybe MSI have something similar?

 

I see you have two sticks that come from the same kit I take it? I suspect the above is your problem.

TuringMachine

Ryzen 5 3600x - Asus Strix B450-F - Asus ROG RTX 2060S Strix AD - Fury Beast 3200 2x16 GB DDR4 - Phanteks P400S - Corsair RM 650x - BeQuiet! Dark Rock 4 - 2x Kingston A2000 NVMe 1TB SSD (RAID 0) - 2x Samsung QVO 1TB SSD (RAID 0) - Seagate Barracuda 3TB

Link to comment
Share on other sites

Link to post
Share on other sites

Yes, Sorry - two sticks of the above kit, and double checked that they were in the correct slots.

And what did you mean about the above problem? I'm comfused

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×