Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

New build won’t recognize my Nvme drive

Agamemnian
 Share

Go to solution Solved by Agamemnian,
4 hours ago, Agamemnian said:

I’ve set it to:

 

Launch CSM: Enabled

Boot device control: UEFI and Legacy OPROM


When I apply the change though at save and exit as soon as it goes back into BIOS and CSM is disabled again 

image.jpg

image.jpg

image.jpg

Sorted it. 

Under the exit menu there was an option for loading EFI profile from USB and when I did that and restarted Nvme showed up. 
 

Windows is now installed and I’m a happy camper. 
 

Thanks for trying to help 

 

Hey guys

 

I’ve put together a new build using an Asus TUF Z690-Plus WiFi D4 and the only storage device I’m using is a Sabrent Rocket Nvme 4.0

 

i know the mobo should support this drive as it can support up to pcie gen 5

 

The problem is when I go into bios under storage info it shows that the device is there.
 

However when I try and use the window boot media it says there are no bootable drives installed. 
 

Going back into bios advanced mode if I go to advanced/Nvme controller and drive information it says there is no Nvme device found. 
 

im guessing there must be a setting somewhere I need to enable. but I’m totally lost. 
 

can anyone help point me in the right direction?
 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Agamemnian said:

Hey guys

 

I’ve put together a new build using an Asus TUF Z690-Plus WiFi D4 and the only storage device I’m using is a Sabrent Rocket Nvme 4.0

 

i know the mobo should support this drive as it can support up to pcie gen 5

 

The problem is when I go into bios under storage info it shows that the device is there.
 

However when I try and use the window boot media it says there are no bootable drives installed. 
 

Going back into bios advanced mode if I go to advanced/Nvme controller and drive information it says there is no Nvme device found. 
 

im guessing there must be a setting somewhere I need to enable. but I’m totally lost. 
 

can anyone help point me in the right direction?
 

 

Try enabling/disabling CSM (Compatibility support module) in BIOS. That might help.

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, Real_NC said:

Try enabling/disabling CSM (Compatibility support module) in BIOS. That might help.

I’ve set it to:

 

Launch CSM: Enabled

Boot device control: UEFI and Legacy OPROM


When I apply the change though at save and exit as soon as it goes back into BIOS and CSM is disabled again 

image.jpg

image.jpg

image.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, Agamemnian said:

I’ve set it to:

 

Launch CSM: Enabled

Boot device control: UEFI and Legacy OPROM


When I apply the change though at save and exit as soon as it goes back into BIOS and CSM is disabled again 

image.jpg

image.jpg

image.jpg

Sorted it. 

Under the exit menu there was an option for loading EFI profile from USB and when I did that and restarted Nvme showed up. 
 

Windows is now installed and I’m a happy camper. 
 

Thanks for trying to help 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×