Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My monitor wont open after I install my new ram

Hello everyone,

I recently purchased an extra 8GB of RAM on top of my already existing 8GB of RAM so that in total I can have 16GB of total RAM. However, there's an issue. let me first explain my overall computer specs listed below.

 

My specs:

Motherboard: Gigabyte A320M-S2H V2 

Graphics Card: AMD Radeon Vega 8 Graphics
Ram: DDR4 8 GB 2133MHz

Processor: AMD Ryzen 3 Mobile 3200G

Drives: 500GB SSD & 500GB HDD

PSU: 700 Watt Power Supply

 

So I just recently bought another 8GB DDR4 Ram, but whenever I install my new ram my monitor doesn't open or display. I tried exchanging their slots with my old ram yet the problem is the same.  I also tried using both ram sticks individually in the two RAM slots that are available on my Motherboard and unfortunately my old ram is the only one working. Is there any solutions I can try? I really need some help since I don't have a lot of knowledge in computer hardware.

Edited by moon12
I double checked my psu
Link to comment
Share on other sites

Link to post
Share on other sites

"unfortunately my old ram is the only one working" 
Then return the new one back to where you bought it

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×