Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My computer freezes and mic stops working often. Send help.

RazGrox
 Share

Sometimes when I game or am looking at something my computer "stutters" or just freezes for a few moments then goes back to normal.

What happens:

- Entire desktop/apps freeze for a second or two.

- Peripherals lock up and I walk in a straight line in game while this happens.

- My microphone doesn't work in discord anymore. It shows up, just doesn't pick up anything. 

- A temporary fix is to just re-plug the mic and it works again(or select my input device in discord to default and then back again)

... for a few seconds then people say I sound like a robot and then cuts out again.

- Audio bugs

 

This is in special circumstances listed below:

- When discord is open

- When I go on the Ubisoft app  (100%)

- Other instances where there is a video playing? Maybe intensive software?

- Sometimes it never happens

- Seemingly randomly

 

What I have done:

- Tried a different mic, other mics do the same thing. It's not the mic.

- Uninstall and reinstalled ALL drivers

- Updated graphics drivers

- Completely re-installed discord

- Unplugged and re-plugged the microphone, used different usb slots

- Frequently checked task manager for weird spikes

 

My Specs:

Mic: USB Mic

OS: Windows 11

MOBO: Gigabyte Aorus X570 Elite

Monitor: Odyssey G9

Keyboard: Glorious GMMK Custom

Mouse: Logi G Pro

CPU: R9 3900X

GPU: RTX 3080 FE

Memory: 2x8 3600MHz G.Skill Cl16

 

 

I assume it's either an issue with my CPU, USB hub, or some software bugging out.

I am at my wit's end on this issue, I can't figure it out. It hate it when I'm playing competitive games and people can't hear me and my game just stops working randomly.

Someone please help.

FX8350,HD7870,H100i,CX750,16GB DDR3,500GB 850 EVO,K70&M65RGB, BenQXL2720Z,ATH-M50X,Blue Snowball,Razer Vespula

Link to comment
Share on other sites

Link to post
Share on other sites

At this point I'd reformat your C:\ drive and reinstall a new copy of Windows and maybe use a mic that uses an actual audio port? 

Work Rigs - 2015 15" MBP | 2019 15" MBP | 2021 16" M1 Max MBP | Lenovo ThinkPad T490 |

 

AMD Ryzen 9 5900X  |  MSI B550 Gaming Plus  |  32GB G.SKILL 3200 CL16 4x8GB |  PowerColor RX 5700XT  |  WD Black SN750 1TB NVMe  |  Corsair RM750  |  Corsair 4000D  |  Dell S2721DGF  |
 

Fun Rig - AMD Ryzen 5 5600X  |  MSI B550 Tomahawk  |  32GB G.SKILL 3600 CL16 4x8GB |  AMD Reference 6700XT  | Creative Sound Blaster Z  |  WD Black SN850 500GB NVMe  |  WD Black SN750 2TB NVMe  |  WD Blue 1TB SATA SSD  |  Corsair RM850x  |  Corsair 4000D  |  LG 27GP850  |

Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 month later...

Did you ever find a fix for this? I am having the same issue with similar computer specs.
 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×