Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

annoying error - a device which does not exits was specified

MOBHUNTER100
 Share

i have lenovo legion 5 laptop ( 8gb single channel ram, amd ryzen 5 5600h ,gtx 1650 gpu) it is my primary machine for my both gaming and work(it came with windows 11 pre-installed), it have 2 nvme ssd slots one is occupied by 500gb and other one is empty so i installed a 1tb XPG SX6000 LITE for storage of games and other stuff, one day laptop started to hang so i checked task manager if something is consuming resources that it shouldn't what i found out is some service of lenovo vantage software consuming cpu and ram up to 45% so thought a clean install of windows and lenovo vantage should do the work, I did the install everything looks fine all drives and devices showing up nothing looks out of places but things started to get wired when i tried to access my secondary storage(xpg 1tb) at first when i tried to access the files it gave me error of "access denied" i searched on internet what could be the possible cause of this and how to fix this. one site says it could be the permissions so i followed the steps and guess what it didn't work tried number of things nothing worked so i formatted the drive and restarted the laptop and now it works normally until i tried to install shadow of the tomb raider epic gave some error after downloading 25% of game, steam did the same after 14% of downloading(saying disk write error) and after some times whole drive vanishes form system even form disk management does not appear until i restart or shutdown the system several times i tried swapping the drive with other slots nothing happen 

 

plzz help 

Link to comment
Share on other sites

Link to post
Share on other sites

So my first guess is that drive is failing as a disk write error is not good. Does that drive work in another system ok?

Are you able to use Crystal Disk mark SMART info check to see drive health?

If that drive works ok in another system, it may be the MB slot, which you can then try another drive in that slot to verify.

Link to comment
Share on other sites

Link to post
Share on other sites

so something happen but not good, I change the drive letter from D to E now XPG 1tb works like a normal drive(like storing files like video and audio ) but the problem is steam and epic both download game 100% and do their verification thing at the time of installing both steam and epic failed, steam give error of data corruption and epic give error of something D0 something like that and most annoying thing is that EPIC is downloading game in E drive(which is XPG 1tb) but trying to install in D(giving error-" you don't have permission to install in drive D") which is not even there, game files exists in E I even tried to launch directly from SOTTR.exe it is launching but give black screen at menu maybe trying to find the epic launcher files to validate itself and forgot to mention one thing when i was changing permission i end the task as it is taking too long but the point is that it is not letting me access the files in the first place. and the Crystal Disk Mark show drive is in good shape as it is brand new I bought it a week ago. 

 

 

 

edit -- something good happen, at last steam was able to install the game in defected drive(i thought it was defective but it's not) cs:go and apex both installed without any difficulty.

but epic have the same problem as before 

help please 😞

 

 

 

and thanks for replying @Frizz 

 

 

Screenshot (1).png

Link to comment
Share on other sites

Link to post
Share on other sites

so something happen but not good, I change the drive letter from D to E now XPG 1tb works like a normal drive(like storing files like video and audio ) but the problem is steam and epic both download game 100% and do their verification thing at the time of installing both steam and epic failed, steam give error of data corruption and epic give error of something D0 something like that and most annoying thing is that EPIC is downloading game in E drive(which is XPG 1tb) but trying to install in D(giving error-" you don't have permission to install in drive D") which is not even there, game files exists in E I even tried to launch directly from SOTTR.exe it is launching but give black screen at menu maybe trying to find the epic launcher files to validate itself and forgot to mention one thing when i was changing permission i end the task as it is taking too long but the point is that it is not letting me access the files in the first place. and the Crystal Disk Mark show drive is in good shape as it is brand new I bought it a week ago. 

 

 

 

edit -- something good happen, at last steam was able to install the game in defected drive(i thought it was defective but it's not) cs:go and apex both installed without any difficulty.

but epic have the same problem as before 

help please 😞

 

edit --- back where i have started, its  happening all over again, drive showing up in bios but not in windows in screenshot 3 as you can see crystal detects the drive but after the restart it disappeared again in (screenshot(2) ) but it is showing in bios i clean installed windows again. In disk management it is showing i tried to delete the volume and create the new volume but again the same error " A device which does not exist was specified" and one time it is showing in explorer but i can't access the files 

 

help 😞

 

 

 

 

and thanks for replying @Frizz 

 

Screenshot (3).png

Screenshot (2).png

screenshot(1).png

Screenshot (6).png

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×