Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Laptop shuts down after a period of time

Hey, 
I recently recieved my new laptop for school however whenever I close my lid for a long period of time (not sure exactly how long im guesstimating around 2 hours) the laptop completely shuts-down and i have to press the power button for it to boot. If I open my lid before my guesstimated time it opens into the sign in screen which is exactly what I want to happen if I open my lid when I wake up in the morning. However right now in the morning all my applications and anything that needs to be manually saved (which isn't a whole lot these days thankfully) is gone. First off im wondering if this normal for laptops in which case you can my dismiss question however if it isn't then is there any way that I can configure it so it doesn't shutdown.

 

Thanks in advance and feel free to ask any questions for any information that could be useful that I haven't provided here. 

 

Below are the current settings for "choosing closing what the lid does" in the control panel. 

Screenshot (2).png

Link to comment
Share on other sites

Link to post
Share on other sites

Check your bios settings. Maybe there's some settings there which makes it switch off

  • CPU
    i3-6100
  • Motherboard
    Gigabyte H110m ds2
  • RAM
    16gb 2400MHz Corsair Vengence
  • GPU
    1660 super
  • Storage
    500GB 860 EVO & 1TB seagate hdd
  • PSU
    Corsair CX750
  • Audio
    Superlux HD660 Reference Closed Back Headphones
  • Operating System
    Windows 10 (1907)
Link to comment
Share on other sites

Link to post
Share on other sites

it's a windows feature and your laptop is hibernating after being in sleep for some time. you have to disable that feature. the steps are:-

 

1. Press Windows key and type edit power plan and press enter.

2. Click on Change Advanced Power Settings.

3. Scroll down and expand Sleep.

4. Now expand Hibernate after and click on Settings (Minutes):. Change the value to 0.

5. Click on Apply and then Ok.

Link to comment
Share on other sites

Link to post
Share on other sites

47 minutes ago, cns00 said:

it's a windows feature and your laptop is hibernating after being in sleep for some time. you have to disable that feature. the steps are:-

 

1. Press Windows key and type edit power plan and press enter.

2. Click on Change Advanced Power Settings.

3. Scroll down and expand Sleep.

4. Now expand Hibernate after and click on Settings (Minutes):. Change the value to 0.

5. Click on Apply and then Ok.

This is currently what shows up under Sleep

 

I own a zephyrus g14 which is widely documented to get quite toasty and I do remember tweaking with something in the regsitery to reveal a hidden setting that disables aggresive boosting of the cpu clock speed. Wondering if you have a guide or if there is a guide for me to follow as I think that is the solution however I just can't find the option. 

 

Screenshot (4).png

Link to comment
Share on other sites

Link to post
Share on other sites

do these things

 

1) go to elevated cmd (run cmd with admin privileges) and run this command:-

powercfg.exe hibernate /off

 

in order to disable hibernate and then restart the pc

 

2) when you want to play a demanding game which is causing high cpu temps click on processor state in the advanced power plan, select max processor state on plugged in and change the value from 100% to 99%. that will disable the cpu turbo boost and the cpu temps will be much less. when you finish put the value back to 100%

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, cns00 said:

do these things

 

1) go to elevated cmd (run cmd with admin privileges) and run this command:-

powercfg.exe hibernate /off

 

in order to disable hibernate and then restart the pc

 

2) when you want to play a demanding game which is causing high cpu temps click on processor state in the advanced power plan, select max processor state on plugged in and change the value from 100% to 99%. that will disable the cpu turbo boost and the cpu temps will be much less. when you finish put the value back to 100%

Thank you so much! 

 

To disable hibernation with a quick google seach it ended up being "powercfg.exe /hibernate off" as it kept coming up with "hibernation state must be on or off" and as I am currently heading to sleep (new zealand baby) I will update this on the situation. I do hope this fixes the problem. 

 

As for the max processor state although I haven't put it through it's paces yet (keyword yet, planning on pushing it tomorrow with a blender render of something I've been working on my main PC) I've applied this on all states (battery + performance aka plugged in) as it does get toasty even on battery power and perhaps as a battery saving measure. I'm not expecting it to do much, but an extra 10 minutes is an extra minutes.

 

Thank you once again, this has been a massive help. 🙂

Link to comment
Share on other sites

Link to post
Share on other sites

A bit of a late update, however the issue is completely fixed. 

 

Thank you so much! 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×