Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

BIOS update error. MY MAINBOARD DOESNT EXIST on the official website

Im fucking done, ive been having problem for the past 5 days now and it came down to memwantimg to update my bios. Well....i cant dowload the update file because MY MAINBOARD DOESNT EXIST !!!! Its an Aorus Z690 Elite DDR4 but the only one on their website is the Aorus Z690 Elite AX DDR4. The file from that one doesnt work on my mainboard. Also, you can buy my mainboard everywhere, but just on gigabytes site, there is no trace of it at all.

 

https://www.mindfactory.de/product_info.php/Gigabyte-Z690-AORUS-ELITE-DDR4-S1700-DDR4-ATX-retail_1430020.html

16387062529004132921594002404180.jpg

16387063209775719476372002517330.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, Grabby said:

Doesnt work still...invalid bios image error

you are using a laptop?

 

usually they have custom bios

your laptop manufacturer should provide the  correct bios

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, MR H. said:

you are using a laptop?

 

usually they have custom bios

your laptop manufacturer should provide the  correct bios

No i dont 

 

Specs new build, never booted :

 

i7-12700k

RTX3080 ti

Z690 Aorus Elite DDR4 

32GB Ram 

bequiet 850w straight power 11

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, rickeo said:

It seems to be right on their page with all the other Z690 boards. 

 

https://www.gigabyte.com/Motherboard/Intel-Z690

 

https://www.gigabyte.com/Motherboard/Z690M-AORUS-ELITE-DDR4-rev-10#kf

 

image.png.06a21b24b8645d83a44d48a0805a9317.png

 

You may have a filter selected that's ruling it out.

No i dont. The mainboard literally does not exist on the .com website

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Grabby said:

No i dont. The mainboard literally does not exist on the .com website

And i dont have the M version because i have 4 ram slots

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Grabby said:

And i dont have the M version because i have 4 ram slots

 

Can you link a picture of the board you have? Or a link to the listing where you bought it?

5800x/3090

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, rickeo said:

 

Can you link a picture of the board you have? Or a link to the listing where you bought it?

Its all in my post already

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Grabby said:

Used that file. Didnt work. Invalid bios image error. Enables legacy boot mode as said on the website. System doesnt turn on anymore. Only fans and RGB turn on

Clear the CMOS then you may need to contact Gigabyte. That is the correct page for your board. 

5800x/3090

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×