Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Bequiet Silent Wing strange noise without dust filter

deadrobotxd
 Share

Hello, i recently bought a silent wing 3 to my case but it makes a vibrating sound when is the filter off, it doesnt really affect when the filter is off but i wonder if something is wrong with the fan or if it is just the case or mounting

There is the clip of how it sounds

Link to comment
Share on other sites

Link to post
Share on other sites

Oh wow that sounds nuts indeed. Good showing it in the video. Did you try to attach it with the screws? It sounds normal if not attached to the case?

 

Look like its running at pretty high RPM also, maybe tone that down a bit.

Link to comment
Share on other sites

Link to post
Share on other sites

Sounds like the fan isn't mounted far enough away from the case and is creating a lot of turbulence.

You could try some rubber fan spacers to see if that creates enough of a space between the case and the fan, something like this:

https://www.amazon.com/Anti-Vibration-Silicon-Fan-Gasket-120mm/dp/B07147CSLS/ref=sr_1_4?keywords=120mm+fan+spacer&qid=1638610746&sr=8-4

 

I had the same issue with my O11 Dynamic case where the bottom fans are mounting flush up against the case, this created a horrible noise with the fans i was using at the time, my solution was to cut a nice big rectangle out of the bottom of the case, this way the only thing impeding the airflow was the fan filter, added some spacers to get the fans a little further away from the filter and now they are basically silent.

Link to comment
Share on other sites

Link to post
Share on other sites

21 hours ago, Sjaakie said:

Oh wow that sounds nuts indeed. Good showing it in the video. Did you try to attach it with the screws? It sounds normal if not attached to the case?

 

Look like its running at pretty high RPM also, maybe tone that down a bit.

Yep sounds normal when is not attached and same issue with screws, must be turbulence like the other guy said, and dont worry the rpm was just to show the sound more clearly  haha

Link to comment
Share on other sites

Link to post
Share on other sites

12 hours ago, Neggy-Z said:

Sounds like the fan isn't mounted far enough away from the case and is creating a lot of turbulence.

You could try some rubber fan spacers to see if that creates enough of a space between the case and the fan, something like this:

https://www.amazon.com/Anti-Vibration-Silicon-Fan-Gasket-120mm/dp/B07147CSLS/ref=sr_1_4?keywords=120mm+fan+spacer&qid=1638610746&sr=8-4

 

I had the same issue with my O11 Dynamic case where the bottom fans are mounting flush up against the case, this created a horrible noise with the fans i was using at the time, my solution was to cut a nice big rectangle out of the bottom of the case, this way the only thing impeding the airflow was the fan filter, added some spacers to get the fans a little further away from the filter and now they are basically silent.

Nice, gonna try getting those and hopefully it helps if not then i will go DIY too.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×