Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Gigabyte Z690 Gaming X - Setting platform key in Bios Secure boot unable to POST

Go to solution Solved by Adrian Hartanto,

Solved by updating bios to a newer version with Q-Flash Plus from Gigabyte.
It will reset the BIOS to factory default

Spec:
- CPU: Intel i5 12600KF
- Motherboard: Gigabyte Z690 Gaming X DDR4
- Ram: Corsair 2x16 GB DDR4

- GPU: Gtx 1060
- Storage: Samsung EVO 850 250GB (It's MBR)
Please need help. My PC won't go thorugh POST.

Previously, Bios is working and setting CMS to Legacy enables me to boot to Windows 10.

So I was trying to upgrade to windows 11 and I need to set secure boot for it.

So I was following a video on setting Platform Key in the bios, disable CMS and Save changes and exit. (My whole purpose is to enable secure boot)

But after that my PC won't go through POST.
And I'm stuck with no solutions yet at the moment.

 

I've tried resetting CMOS and jumper many times. but it didn't work.

Motherboard shows that the beep stucks at VGA red light

Link to comment
Share on other sites

Link to post
Share on other sites

Solved by updating bios to a newer version with Q-Flash Plus from Gigabyte.
It will reset the BIOS to factory default

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×