Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Why is my 6900xt underperforming?

bigsmithyrogers
 Share

Ok so I have recently upgraded from a 1660 super to a 6900xt. I have a MSI MAG X570S Tomahawk MOBO, a ryzen 7 3700x, a 850w Corsair psu. Most recent version of bios. Vsync off. I am trying to play apex legends at 1440p at 165hz, but my fps is not stable or anywhere near what I’ve seen other gamers with similar specs have. I can’t seem to hold 165 stable even on low settings and high settings I get 100-120 fps and it even drops under 100 sometimes. Keep this in mind that everything’s on the lowest settings and my friend said his 2080 super performs better than mine in 1440p. I guess I just expected my card to smash apex legends in 1440p with stable fps at least on low settings considering the 6900xt is supposed to be the top shelf card in the amd market. My thermals and everything are normal all drivers recently updated. Did a windows reset and reinstalled everything so I’m not sure what else to try.

Link to comment
Share on other sites

Link to post
Share on other sites

CPU/RAM bottleneck.

CPU: i7-8700k 5GHz@1.25v | MoBo: Asus ROG Maximus X Formula | RAM: G.Skill F4-3600C15D-16GTZ @4000CL17GPU: RTX 2080Ti | PSU: Evga Supernova G2 750w | 

Case: Lian Li 011D XL | Storage: Samsung 970 EVO M.2 NVMe 500GB, Crucial MX500 500GB | Soundcard: Soundblaster ZXR | Mouse: Razer Viper Mini | Keyboard: Razer Huntsman TE Monitor: DELL AW2521H @360Hz |

 

Link to comment
Share on other sites

Link to post
Share on other sites

Make sure your ram is in dual channel mode firstly, and that xmp is enabled.

 

You can check with CPU-z

Link to comment
Share on other sites

Link to post
Share on other sites

Make also sure GPU is running at 16x PCI-E.


You can check with GPU-z

CPU: i7-8700k 5GHz@1.25v | MoBo: Asus ROG Maximus X Formula | RAM: G.Skill F4-3600C15D-16GTZ @4000CL17GPU: RTX 2080Ti | PSU: Evga Supernova G2 750w | 

Case: Lian Li 011D XL | Storage: Samsung 970 EVO M.2 NVMe 500GB, Crucial MX500 500GB | Soundcard: Soundblaster ZXR | Mouse: Razer Viper Mini | Keyboard: Razer Huntsman TE Monitor: DELL AW2521H @360Hz |

 

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, Aragorn- said:

Make sure your ram is in dual channel mode firstly, and that xmp is enabled.

 

You can check with CPU-z

I did a windows reset, reinstalled the the drivers, put ram on xmp mode in bios. Shows my 16gb of ram running at 32000mhz on task manager

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, DarkSmith2 said:

Make also sure GPU is running at 16x PCI-E.


You can check with GPU-z

 

GPU.gif

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, bigsmithyrogers said:

I did a windows reset, reinstalled the the drivers, put ram on xmp mode in bios. Shows my 16gb of ram running at 32000mhz on task manager

use CPU-Z and check its running in Dual channel mode.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×