Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

I need some help with my GPU!!!

2enty1
 Share

Hello guys, I just wanna know if there won't be any problem with this? You can see that I circled the part where there are bents and the other one is like falling off. I wanted to know if it can affect the GPUs performance or maybe it won't display? since I can't test it yet cause I'm waiting for my PSU to arrive.

IMG_20211130_200723.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Welcome to the forums!

If those small diodes are falling off that's a problem... the "bent" one was probably just soldered that way

Is it plugged in? Is it turned on? Are you sure? No, really. 

List of my systems:

Main PC:

Spoiler

HP z620 workstation, 2x Xeon e5-2690 v0, EVGA GTX 980 SC, 8x4gb DDR3-1333, 2x 2tb HDD, 1tb boot SATA SSD, Windows 10 Pro

Linux system:

Spoiler

ProDesk 600 g1 SFF, i5-4590, Quadro k620, 2x4gb DDR3-1333, 64gb boot SSD, 250gb storage HDD from the ewaste pile with many bad sectors, Ubuntu 20.04 LTS

XP system:

Spoiler

Compaq DC7600 SFF, Pentium 4 HT 631, MSI GT 210 passive, 2x512m DDR2-667, 80gb Spinmaster HDD

Testbench:

Spoiler

Optiplex 760 board, GameMax VP-600 PSU, 4x 64gb AliExpress SSD (Windows XP, Vista, 7, 10), 1tb HDD (storage)

(currently has a Core 2 Quad Q9550 and 4x2gb DDR2-800 but I change its config frequently)

 

Link to comment
Share on other sites

Link to post
Share on other sites

24 minutes ago, Mel0nMan said:

Welcome to the forums!

If those small diodes are falling off that's a problem... the "bent" one was probably just soldered that way

I mean only the other side is holding it and the other side is deatched. Can i fix this by soldering it? Is there wont be any problem if i do that?

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, 2enty1 said:

I mean only the other side is holding it and the other side is deatched. Can i fix this by soldering it? Is there wont be any problem if i do that?

Look it came off. Can this still work?

20211130_214327.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, BiotechBen said:

Without knowing what part that is that the resistors fell off of, can't say for sure. What graphics card is it?

 

(Edit)

It would appear that that is part of power delivery and management, a synchronous buck controller

https://www.datasheetq.com/datasheet-download/592305/1/Richtek/RT8802A

Its zotac gtx770 4gb variant

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, 2enty1 said:

Its zotac gtx770 4gb variant

Given the components that are now missing, it could power up fine and work, or it could release the magic blue smoke next time it draws power. Its up to you if you want to risk it.

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, BiotechBen said:

Given the components that are now missing, it could power up fine and work, or it could release the magic blue smoke next time it draws power. Its up to you if you want to risk it.

What do you mean by magic blue smoke?

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, 2enty1 said:

What do you mean by magic blue smoke?

Kablooie, hasta la Vista, buh bye, poof.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×