Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

HELP- I recently got a 6600xt and getting low fps, low gpu clock speed and stuttering

nycon
 Share

I just recently got a 6600xt to add onto my current build, which has a Ryzen 5 3400G and was using integrated graphics. Now after adding the graphics card, I am getting low fps in games like Warzone (60fps on all low settings) and Valorant (120 fps and stuttering on low settings). In the case of Valorant, my fps actually went lower than before the upgrade and I don't know why. I ran MSI afterburner on Rust and I saw I had 50% gpu usage with 1400mhz which is much lower than the base clock speed and 70% cpu usage. The temperature of the GPU was only 50 degrees. Can someone help.

Specs: 
Ryzen 5 3400g
Sapphire pulse 6600xt
2x8gb 3000mhz ram
550w power supply

I have tried: 
Remove old drivers with ddu and downloading latest drivers. I have tried updating bios and chipset drivers.

Link to comment
Share on other sites

Link to post
Share on other sites

33 minutes ago, Hokahn said:

Have you tried to update the drivers? 

Yea I updated graphics drivers using ddu and I updated bios and chipset drivers

Link to comment
Share on other sites

Link to post
Share on other sites

Really dumb question but since you were using and apu before this, are you connected to the 6600xt for display out? 

If yes, something else to check is to make sure you force video to run through your gpu in the BIOS instead of the apu

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, arilmikhail said:

Really dumb question but since you were using and apu before this, are you connected to the 6600xt for display out? 

If yes, something else to check is to make sure you force video to run through your gpu in the BIOS instead of the apu

Yea I’m connected to the gpu for the display. How do I force the video to run through my gpu in bios?

Link to comment
Share on other sites

Link to post
Share on other sites

10 hours ago, nycon said:

Yea I’m connected to the gpu for the display. How do I force the video to run through my gpu in bios?

The steps slightly differ from motherboard to motherboard (my steps follow a gigabyte bios layout), but in general,
 

1. Restart the PC
2. Press and hold the "Del" button on your keyboard (Or whatever equivalent it is to open bios settings)
3. Navigate to either peripherals or chipset
4. Ensure you have your initial display output as PCIe 1 Slot (or whatever slot you have your 6600xt inserted in)
5. Locate "Internal Graphics" 
6. Disable that and test. Otherwise, try "auto" and test again. 

7. Honestly sometimes just resetting everything to "optimised defaults" in the bios helps get it running well too


If this still didn't help then perhaps try these next steps,

 

1. From desktop, right click and select display settings
2. All the way the bottom of the screen now there should be graphics settings
3. Now you should be able to "browse" for specific apps
4. Try selecting a game you want to test (i.e. Halo Infinite) (Locate your SteamLibrary > Steamapps > common > Halo Infinite > HaloInfinite.exe)
5. Now the app should pop up in the list below
6. Click options and select High Performance (or whatever the best 6600xt option is)

 

*If it doesn't show up, your probably not running the right gpu drivers or that there is some fringe case hardware incompatibility between your Motherboard and GPU
**If the first method didn't work, I would recommend resetting your bios either by "Load Optimised Defaults" and adjust what you specifically want (XMP and Overclocking that you're comfortable with) or clearing the CMOS

I hope this helps

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, arilmikhail said:

The steps slightly differ from motherboard to motherboard (my steps follow a gigabyte bios layout), but in general,
 

1. Restart the PC
2. Press and hold the "Del" button on your keyboard (Or whatever equivalent it is to open bios settings)
3. Navigate to either peripherals or chipset
4. Ensure you have your initial display output as PCIe 1 Slot (or whatever slot you have your 6600xt inserted in)
5. Locate "Internal Graphics" 
6. Disable that and test. Otherwise, try "auto" and test again. 

7. Honestly sometimes just resetting everything to "optimised defaults" in the bios helps get it running well too


If this still didn't help then perhaps try these next steps,

 

1. From desktop, right click and select display settings
2. All the way the bottom of the screen now there should be graphics settings
3. Now you should be able to "browse" for specific apps
4. Try selecting a game you want to test (i.e. Halo Infinite) (Locate your SteamLibrary > Steamapps > common > Halo Infinite > HaloInfinite.exe)
5. Now the app should pop up in the list below
6. Click options and select High Performance (or whatever the best 6600xt option is)

 

*If it doesn't show up, your probably not running the right gpu drivers or that there is some fringe case hardware incompatibility between your Motherboard and GPU
**If the first method didn't work, I would recommend resetting your bios either by "Load Optimised Defaults" and adjust what you specifically want (XMP and Overclocking that you're comfortable with) or clearing the CMOS

I hope this helps

Thanks alot, I really appreciate it. I will try these steps and let you know if it fixes the issue

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×