Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How good is AMD Ryzen QC?

alberttu
 Share

Just bought a new 5600G with new motherboard and new ram, boot into bios once, reboot and it wouldn't post. Two new motherboards and three sets of new ram later, still wouldn't post. So it got to be the CPU,right?

 

Any idea? Thanks in advance.

Link to comment
Share on other sites

Link to post
Share on other sites

What models are your motherboard and RAM?

 

Have you checked the motherboard specs to make sure the processor is compatible?

Have you updated the BIOS? Some motherboards may only be able to support certain processors once their BIOS has been updated. 

Link to comment
Share on other sites

Link to post
Share on other sites

I tried two MB one is ASUS B550M-Zaku, the other one is ASUS B550M-Plus (WIFI). They are basically the same board. 

4 different sets of RAM, Curcial DDR4-2666 (2x4GB), T.Force VolcanZ DDR4-3600 (2x8GB), G.Skill Ripjaws V DDR4-3600 (2x8GB), Patriot Viper DDR4-3200 (2x8GB), the last two was listed on ASUS website as supported.

I also try updated both MB bios to their latest. 5600G is listed as supported.

Giving that all the components are new. I cannot verify if any of them are working.

Thanks for any help and advise.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×