Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows terminal profile to run a command on start?

Go to solution Solved by C2dan88,

Just type out the ssh command without cmd.exe infront of it for the commandline option. How I ssh into my pi

 

pi.PNG.851c534734abc9dec6ee6eea8c97af4b.PNG

Ive recently installed windows terminal on my main maching, and its great. Tabs, multiple command lines (WSL!!) in the same window, its all amazing!

I use SSH to connect to my rpi a lot, and it would be a lot easier to have command prompt run ssh user@ip on opening of RPI profile, but just having it run  

"cmd.exe 'ssh user@ip'" 

doesnt worrk and spits an error.

cmd.exe 'ssh user@ip'

doesnt do anything.


How would I achieve this?

I could use some help with this!

please, pm me if you would like to contribute to my gpu bios database (includes overclocking bios, stock bios, and upgrades to gpus via modding)

Bios database

My beautiful, but not that powerful, main PC:

prior build:

Spoiler

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Try using:

cmd.exe /k "ssh user@ip"

 

If you've set up a custom SSH port, you'd need to also specify it here as:

cmd.exe /k "ssh user@ip -p port"

 

Should look like this in your profile (minus all the German text 😉)

EDIT: Forgot to mention, at least on my machine, that field tends to not like manually entering the @ symbol, so copy the entire command you intend to use and just paste it, that way it should work, if you're experiencing the same silly behavior.

image.thumb.png.0035de9a57f08828dd8f3295e750c5de.png

Edited by Avocado Diaboli
Additional info

And now a word from our sponsor: 💩

-.-. --- --- .-.. --..-- / -.-- --- ..- / -.- -. --- .-- / -- --- .-. ... . / -.-. --- -.. .

ᑐᑌᑐᑢ

Link to comment
Share on other sites

Link to post
Share on other sites

Just type out the ssh command without cmd.exe infront of it for the commandline option. How I ssh into my pi

 

pi.PNG.851c534734abc9dec6ee6eea8c97af4b.PNG

Link to comment
Share on other sites

Link to post
Share on other sites

57 minutes ago, Avocado Diaboli said:

cmd.exe /k "ssh user@ip"

 

I totally forgot you had to mark what to run...

lol whoops

but for some reason it still does nothing...

52 minutes ago, C2dan88 said:

Just type out the ssh command without cmd.exe infront of it for the commandline option. How I ssh into my pi

 

pi.PNG.851c534734abc9dec6ee6eea8c97af4b.PNG

This works, thanks!

I could use some help with this!

please, pm me if you would like to contribute to my gpu bios database (includes overclocking bios, stock bios, and upgrades to gpus via modding)

Bios database

My beautiful, but not that powerful, main PC:

prior build:

Spoiler

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×