Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Radeon R9 380 issue

Hi!
I bought a Sapphire R9 380 ITX Compact 2GB graphics card recently. It works fine in another computer but not mine. The problem is very strange. Sometimes the computer posts with the GPU inserted but there is no signal. In other cases it doesn't even post. I got a display out if it once or twice. I even played on it. But as soon as I restart my computer it doesn't work again. I tried it in my brother's computer and it works all the time even after several restarts. I had an RX 590 before this GPU and there were no issues with it. Computer works fine with integrated graphics.

Things I've tried:
-Reseating GPU multiple times
-Clearing CMOS
-Reseating RAM sticks
-Uninstalling previous drivers
-Using other PCIE slot
-Cleaning motherboard PCIE slots
-Disabling iGPU in BIOS
-Trying another monitor

My build:
-Asrock B85M Pro4 motherboard
-2x4 GB Corsair Vengeance LP 1333Mhz DDR3 RAM
-Intel core i5 4460 CPU
-FSP Raider 550W 80+ Silver rated PSU
-240 GB Adata SSD + 1TB Toshiba HDD

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×