Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Upgraded BIOS with a dual booted Linux / Windows. Windows Boot no longer Works

Monkee369
 Share

Gigabyte AB350-GAMING 3 (Socket AM4/B350/DDR4/S-ATA 600/ATX)
Corsair CP-9020048-UK Builder Series CX600 ATX/EPS 80 PLUS Bronze Power Supply Unit, 600 W
AMD Ryzen 5 1600 Desktop CPU - AM4
ASUS GeForce DUAL-GTX1060-O6G 6 GB Graphics Card
Corsair CMK16GX4M2A2400C16 Vengeance LPX 16 GB (2 x 8 GB) DDR4 2400 MHz C16 XMP 2.0
Samsung 850 EVO 500 GB 2.5 inch Solid State Drive

Western Digital WD10EZEX 1 TB PC Hard Drive

 

Originally I wasn't going to upgrade my BIOS however I decided I wanted a new CPU so now im here.

 

As the title says I have tried to upgrade my bios and in doing so somehow messed up my Windows Boot whereas Linux is fine.

This happens on both a USB with Windows 10 copy and my SSD partition.

When both the USB & W10 Partition load up I see the windows Logo for a fraction of a second and goes into reboot. Can't even get advanced settings or safe mode

I am currently using GRUB bootloader and think that is could be the cause but not sure of any workarounds or any idea if that's correct.

I was also thinking about either re-flashing to the working F10 or force the backup BIOS chip to do it's thing but I don't want to do anything without thinking

I have checked all of the notes on the Gigabyte website so I was aware which ones I could skip and prior install notes however I didn't want to skip a full 10 version so went for F20

 

To replicate what I did I first Flashed from BIOS Version F8 -> F10 & that was fine

But when I Flashed from BIOS Version F10 -> F20 that's when it stopped working

Also I decided maybe it was a bad flash so I updated to F21 with no change  

 

Does anyone know what the best course of action for resolving something like this is? 

Honestly feel like a damsel in distress lol. Someone please help me thanks 🙂 

Link to comment
Share on other sites

Link to post
Share on other sites

FYI If theres a solution for this I would rather for the rest of the BIOS upgrades that I use windows only and remove linux partition. Everything has been backed up so it's fine

Also Fast & Secure boot have been disabled

Link to comment
Share on other sites

Link to post
Share on other sites

UPDATE: A downflash worked and now on latest BIOS version. F20 seemed to be an unstable flash for me and went straight to F30 then F31, F40, F51 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×