Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

'Internet not connected' but it is, on some apps...

Hello from across the pond,

 

I will try to be brief but descriptive. I've recently had a brand new FTTP line installed. My provider is Zen Internet.

They provided me with the following hardware upon installation (I'm well aware of the ironic name):

https://en.avm.de/products/fritzbox/fritzbox-7530/

 

Background information

 

The technician installing the fibre cable into the house left me with the following setup:

Raw Fibre Cable -> OpenReach Nokia ONT (See PDF manual here) -> Fritz!Box 7530 (via CAT5e to the Fritz!Box's WAN port).

 

He left without setting up a connection to any device, simply explaining "If I come back, it's not working. If I don't come back, it'll work and have a great day."

I connected a CAT7 cable (messily) straight to my desktop upstairs (see full parts list below) and tested the connection. DOA.

I log into the router settings via 192.168.X.X (I can't remember what the last digits were now, they've since changed.) and input my ISP's login details and huzzah. My 300Mbit/s down and 45Mbit/s up link is made.

It may be important to note I don't know what configuration the technician left the Fritz!Box in when he left it 'working'.

 

My next problem was shocking wifi coverage upstairs in the other side of the house. Understandable, the ISP modem/routers are usually steaming hot garbage right?

I already had a Nighthawk D7000v2 (see manual here) from way back, so the fix seemed simple. Swap out the Fritz!Box for the Nighthawk.

 

I did manage to get a working connection this way, but then, even over the same CAT7 cable straight to the Nighthawk I could only get 150Mbit/s down and 45 up.

Odd that it was exactly half my raw line speed down right?

I decided it's too difficult to diagnose and repair this issue, and I thought of a better idea to circumvent the issue entirely anyway.

Why not use the Fritz!Box as a modem & router, run a CAT7 cable up the stairs to the nighthawk (put in AP only mode) which I can then wire CAT5e to the Desktop in a non-messy fashion.

Huzzah again. 300 down, 45 up.

 

Note: As part of the setup, I run DNSBench and change my DNS settings on the Fritz!Box from ISP provided to the fastest two from the benchmark.

 

Actual problem

 

image.png.2eb6be673210658090f5ece5d9ce6073.png

As you can see, apparently I'm not connected.

But if I click this icon:

image.png.2cd7369d481302f2ccdbc128da214d81.png

You can see I'm connected to both the Nighthawk at the top of the stairs via Ethernet, and also to the wifi connection it's creating.

Nothing changes if I'm connected to either one or both connections.

 

I still get 300 down and 45 up on everything that works (chrome, steam, MS Teams). However, some apps are reporting no network connection at all.

 

  • Spotify states "This content is not available" when trying to play individual songs, but allows me to shuffle any playlist and browse freely.
  • Outlook (now with no account set up) reports "Unable to connect" immediately on startup.
  • When opening on startup, Teamviewer never establishes an internet connection. After exit and reopen, it works fine.
  • The Microsoft store opens, and loads content, then hilariously throws up a 0x800704cf "It doesn't look like you're connected to the internet..."
  • The Adobe Creative Cloud Desktop app reports "No internet connection".
  • My desktop's Plex server went offline mid-movie twice.
  • Windows Update failed (0x800704cf)

My desktop is the only affected device on my network, all other laptops, ipads and phones function flawlessly.

 

Here are the steps I've taken to fix the problem, to no avail:

  • Power cycle (many, many times)
  • ipconfig /release
  • ipconfig /flushdns
  • ipconfig /renew
  • netsh int ip reset
  • netsh winsock reset
  • Set a static IP for the desktop
  • Turned on IPV6
  • Turned off IPV6
  • Turned off QoS
  • Turned off Traffic Monitoring
  • Uninstall and reinstall all offending apps
  • Updated Intel Graphics driver (my only out of date)
  • Windows network troubleshooter on every network device available

I want to avoid doing a fresh windows install, as I'm sure I've screwed up a setting in either the Nighthawk or Fritz!Box that is causing the issues, but I can't get past the fact that only my desktop has these issues.

 

If you have any suggestions, I'm all ears.

 

As a side note, my PS5 reports errors connecting to the DNS sometimes (or some such, I'll get more details in the next couple of days). Maybe once or twice during a few hours of playing.

Any thoughts there? I've added a static IP for it in the Fritz!Box and given it access to open and close ports.

This is only minor as it doesn't affect gameplay (yet).

 

Desktop Specs:

CPU: I7 9700k
CPU Cooler: NH D-15
Motherboard: Aorus Z390 Pro
Memory: 64GB 3200C16 Vengeance Corsair LPX
Storage: Sabrent M.2 NVME PCIe Internal SSD (1TB, PCIe 3.0)
Storage: WD Blue 2TB

Storage: WD Blue 3TB 

Storage: WD Blue 1TB (or similar, I think one or two of these drives were salvage?)

Storage: 2TB 970 Evo M.2
Video Card: Aorus Master 3090 v1
Power Supply: Corsair RM850x 80 PLUS Gold, 850 Watts, Fully Modular ATX Power Supply Unit - Black
Operating System: Microsoft Windows 10 Pro (x64) 2004 19042.746
Case: Fractal Design R6

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×