Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Computer not turning on after installing new motherboard

Right so I brought I whole lot of bits for my computer PSU (Corsair 850W good something), Motherboard (ASU’s Tuf z390 plus gaming) and Graphics card (3070ti Suprim X) I installed it all the find out it wasent showing signs of any power no light nothing, so I changed out my new motherboard for my old one (Asrock b360-HDV) and it turned on working fine so the PSU and Graphics card should be fine right? So I made a repair ticket and sent back the motherboard… BOX come back and say it is deemed at not faulty so then send it back to me. About 3 weeks later when I can be bothered to install it and I put all the bits in and no surprise it doesn’t not turn on still! Idk if I’m plugging stuff in wrong but everything seems fine, I can add in pictures if you want me to of my front panel connectors I got a Corsair 465x btw but I need this to be fixed or something :/

Link to post
Share on other sites

First Check if your motherboard comes with an LED indicator or not. If there's no LED, then connect your PSU, GRAPHICS, CPU & RAM to the motherboard. Dont install the cooler & data drives at this time. After that try switching it on. When the PSU fans start spinning, then Touch the CPU directly with your finger. If the CPU is heating up, then your Motherboard might be fine. And your RAM might be acting up.

This will work if you have an LED or No LED indicator on the board.

Link to post
Share on other sites

I have got LED signals I think? When I just plug in my psu cable no lights come on or nothing…

image.jpg

Link to post
Share on other sites

Yes you have LED on the board. Try doing the steps that i have written above.

Remember you gotta turn on that switch near the LED after connecting your PSU.

 

Link to post
Share on other sites

To get power to the motherboard you should have connected the 24 pin cable and the 8 pin on the top left part of the motherboard.

 

jjXfIyNpHZfmVYfO_setting_xxx_0_90_end_80

 

Just double check the cable connections

Link to post
Share on other sites

Yes, I have done that a cable called cpu on it to the top left then the 24 pin one obviously in the biggest slot

Link to post
Share on other sites

Update: literally unplugged and plugged everything in still no power 😕 can someone else please join this and help me ?

Link to post
Share on other sites

Have you tried jumping the pwr pins instead of using the power switch on the case?

Current Build

AMD Ryzen 2600

Stock cooler

Asus ROG B450f gaming Mobo

1tb SKHynix m.2

WD 1TB HDD

Asus ROG Strix RX 5700xt

Thermaltake Toughpower 650w DPS RGB 80+Gold

16 Gigs ddr4 3000 gskill ram

Phantek fans

Phanteks P400TG

 

Laptop

Eluktronics Prometheus XVII

Ryzen 7 5800h

32 gigs ddr4 Corsair ram

Nvidia rtx 3080 max-p

17.3 qhd 165 hrz screen

1tb Samsung m.2

1tb WD black m.2

Link to post
Share on other sites

Where are the pwr located on this motherboard? And how do I jump it? For now I have my old motherboard installed until I can get it fixed 

Link to post
Share on other sites

For clearing the jumper:

There are those 2 pins as in the image  posted by @immanicguy. There must be a piece of plastic (or jumper) mounted on those 2 pins. Take that jumper out to reset the BIOS and then put it back.

Link to post
Share on other sites

To jump the power pins instead of using the pre-installed power button on the board, Look for a set of 9-pins on the board labelled as Front IO or Front Panel. It will include 2 Power Pins. Now take a piece of small, long metal piece and short those 2 pins with it.

Try a youtube tutorial for this. Because it might not be easy for you if you havent done it before.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×