Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Crosshair 7 (x470) gets stuck at post screen. Have to clear CMOS nearly every restart or else it will stay stuck forever. No Q Code being given.

Whenever I restart my computer the last new days it will get stuck at the "press F2 to continue to bios screen" - Pressing F2 does nothing, doing nothing leaves me stuck there until I turn the machine off. I have waited 30 minutes before and nothing happened, so its not just being slow. Additionally after re-flashing my bios to various versions the same issue still happens but a new error started occurring. On the american megatrends screen, I have been getting a new error stating "your system may not be fully stable press f1 to setup" - Pressing f1 takes me back to the bios, and its a whole loop. If I were to turn off the "Wait for F1" in the bios, itll usually boot to windows but its really intermittent. Typically, this is what will get me into windows.

 

Turn off PSU for a minute or two

Turn PSU back on, clear CMOS

Wait for post screen

Clearing CMOS takes me to the American megatrends screen and I can press F1 to enter BIOS. BIOS will behave normally, and I can even select any settings I want. Usually from here itll boot normally, but I did have a problem of my SSD just not being detected but replugging it in solved that, so no idea if thats a related symptom. 

From here the PC will boot to windows normally. Performance seems fine, I played a few hours of warzone with normal performance, f1 2021 as well.

 

I am just lost at what is actually causing this. I have re-seatted my ram into new slots, tried my graphics card with and without the riser cable, tried posting with 1, 2, and no SSDs plugged in, tried new sata cables, new power cables for the SSD. 

 

Is it possible this is windows install related? My windows install has been acting kinda strange in the past but honestly who knows. I am thinking its a motherboard issue, but like I said I am about as lost as I can be. I cant narrow down the root cause. I dont have any other CPUs or RAM to try.

 

 

Specs:

Motherboard - Crosshair 7 (no wifi) x470

RAM - G.Skill ripjaws 3200mhz CAS 14 (Samsung B-Die)

GPU - Reference model 3060ti (currently using it WITHOUT the riser cable for stability issues)

CPU - Ryzen 3700x (never been overclocked, ran with stock cooler. temps are fine, dont think issue is CPU related)

Storage - Samsung 870 evo and WD blue both 1tb

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×