Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

So I have built my first system using these parts;

Ryzen 5 5600x

NZXT Kraken x53

Trident Z 16gb 3600mhz

3070 Gigabyte Aorus

All of these parts went into the NZXT H510i case. So to get started, I built the system and plugged the PSU in only to find out that the cpu and dram debug lights were flashing along with a continuous beep code and I figured I had to update BIOS for the new 5600x. When I tried flashback, using two different USB drives, both formatted to FAT32 and having the bios and only the bios in the drives and renaming it to "creative.rom" per the manual and the flashback light just never turns on, I dont know what to do, Ive tried resetting CMOS, and even reseating the battery along with taking out the CPU and RAM to try to flashback and it still doesnt work. I dont have another CPU to update the BIOS so im stuck looking at my build and not being able to use it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×