Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ipad charges so slow

what may cause this problem it can take like 6hrs just to charge to 25% - 30%

Link to post
Share on other sites

Dirty contacts on the end of the wire that plugs into the iPad.. or broken wires inside of the sheathing (the rubber coating outside the wire)..聽 If the cable has any kinks or twists in it.. that is more than likely your issue.聽 Or if the cable isn't solid when plugged into the charging port - if it has any wiggle to it while plugged in, broken solder points on the PCB inside it..

Ryzen 7 5800X聽w/Noctua NH-D15S / Gigabyte RTX 2070 Super / 32Gb聽Vengeance 3200 (4x8) / MSI X470

Sabrent Rocket 512Gb m.2 / 2x1Tb T-Force Vulcan SATA SSD / Seasonic Focus GX-750

Dell S3220DGF - curved 32" 1440p 165Hz

Ryzen 5 3600 w/Stealth / MSI RTX 2060 Gaming聽Z / 16Gb Vengeance 2666 / MSI X470

Intel 660p 1tb / 1Tb T-Force Vulcan SATA SSD / Thermaltake Smart 600W 80+

HP 32Q - 32" 1440p 60hz

Link to post
Share on other sites
14 minutes ago, si1enze said:

Dirty contacts on the end of the wire that plugs into the iPad.. or broken wires inside of the sheathing (the rubber coating outside the wire)..聽 If the cable has any kinks or twists in it.. that is more than likely your issue.聽 Or if the cable isn't solid when plugged into the charging port - if it has any wiggle to it while plugged in, broken solder points on the PCB inside it..

cable is not loose port seems to be fine as it comes up charging when plugged and it i wiggle the cable it never disconnects from charging cable is fine as its charging my iphone 6s+ fine

Link to post
Share on other sites
56 minutes ago, gt710 said:

what may cause this problem it can take like 6hrs just to charge to 25% - 30%

Are you using a cheap quality cable? Are you using a different charging brick?

Link to post
Share on other sites

What power adapter are you using? iPads take a long time to charge, but it shouldn't be that slow.聽

Phobos (Primary Desktop)

AMD Ryzen 7 2700, 16GB 3000MHz DDR4, ASRock B450 Steel Legend, 6GB Nvidia GeForce GTX 1660 Ti,聽4GB XFX AMD Radeon RX 570, 960GB Crucial M500, 1TB WD Blue SN550, 2TB Seagate BarraCuda, 450W Corsair CXM, Corsair Carbide 175R, Windows 10 Pro for Workstations

York (NAS/Plex Server)

Intel Core i7-2600K, 16GB 1600MHz DDR3, ASUS P8Z68-V, 1GB PNY Nvidia GeForce GTX 550 Ti, 240GB Kingston V300, 2x3TB HDD, 3x2TB HDD, 750W Dell PSU, Dell XPS 630i case, Windows Server 2019

Yet to be named (Secondary Desktop)

Intel Core i7-2600, 24GB 1600MHz DDR3, ASUS P8Z68-V, 2GB Nvidia GeForce GTX 680, 1TB Samsung 860 EVO, 700W EVGA BQ, Fractal Design Focus G, Windows 10 Pro for Workstations

Mid 2011 27" iMac (General Purpose Desktop)

Intel Core i5-2400, 16GB 1066MHz DDR3, Apple Z68 Logic Board, 1GB AMD Radeon HD 6970M, 500GB Crucial MX500, 1TB Seagate BarraCuda, macOS High Sierra

Link to post
Share on other sites
5 hours ago, BondiBlue said:

What power adapter are you using? iPads take a long time to charge, but it shouldn't be that slow.聽

the one from my iphone 6s +

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now