Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Hi I recently got a new ups forza nt-1011
https://www.forzaups.com/products/internal/NT-1011-eng
 
Now, I've never used a ups before until now so I followed the instructions that are in the manual, pretty much just plug in the ups to the outlet and leave it charging without anything plugged in the ups for 6 hours at least, which is what I plan to do, but one thing I noticed is a peculiar smell, it's like" new plastic" , not exactly burn but it's odd, is this normal?
also can i turn off the psu when i no longer use it during the day ? or does it have to be "on" all the time?
 
thanks for your time o/
 
Link to post
Share on other sites
4 minutes ago, squallypo said:
Hi I recently got a new ups forza nt-1011
https://www.forzaups.com/products/internal/NT-1011-eng
 
Now, I've never used a ups before until now so I followed the instructions that are in the manual, pretty much just plug in the ups to the outlet and leave it charging without anything plugged in the ups for 6 hours at least, which is what I plan to do, but one thing I noticed is a peculiar smell, it's like" new plastic" , not exactly burn but it's odd, is this normal?
also can i turn off the psu when i no longer use it during the day ? or does it have to be "on" all the time?
 
thanks for your time o/
 

Yep.

 

New power supplies tend to stink too.  You have to wait for the excess lamination on the magnetics to completely burn off.  Could also be flux, but most of that burns off in the burn in chamber.

 

 

Link to post
Share on other sites
2 minutes ago, jonnyGURU said:

Yep.

 

New power supplies tend to stink too.  You have to wait for the excess lamination on the magnetics to completely burn off.  Could also be flux, but most of that burns off in the burn in chamber.

 

 

thank you for letting me know, i really wanted to be sure it wasnt something toxic, which i hope it isnt.

it has been charging for at least 3hours and a half so far, the smell is still there so just wanted to make sure, the ups its not hot to the touch btw just warm.

Link to post
Share on other sites
13 hours ago, squallypo said:

thank you for letting me know, i really wanted to be sure it wasnt something toxic, which i hope it isnt.

it has been charging for at least 3hours and a half so far, the smell is still there so just wanted to make sure, the ups its not hot to the touch btw just warm.

The hotter the UPS gets, the quicker the smell will go away.  🙂

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×