Jump to content

Service Host DNS Client slowing PC

bepiscan
 Share

Hi, I've been having an issue for some time now where my PC will randomly stutter or slow to a complete stop. I've found that this is because the process Service Host DNS Client is taking up lots of power.
I've tried everything I can find online but nothing has worked. When it spikes in power usage it isn't using massive amounts of network or CPU or anything like that, only power.
It happens when I'm playing games, when I'm in a discord call, or basically any time something is happening.

The things I have already tried are listed below.

Updating Windows
Virus scan
Clearing event viewer logs
Disabling BITS and Wuauserv

Deleted the software distribution folder

Flushed DNS resolver cache
Disabling DNS client
Updating drivers
Changing DNS from ISP to someone else

OS is windows 10 64 bit

600 watt PSU
ryzen 5 3600x
16 gigs of ram
1660 super

Any help would be greatly appreciated as I'm at my wits end.

Link to comment
Share on other sites

Link to post
Share on other sites

Done some of my own googling, and have some related prior knowledge so I'll give it a shot 😛
Issues with dnscache/DNS-Client are normally caused by:
 - Issues accessing the hosts file (too big, slow drive, etc)

 - High load from an application

 

I notice that you haven't actually mentioned any performance issues other than seeing high power usage. Is this true, and your just concerned about the power?
If so, it's not something I would worry about. It's job is to act as a local DNS cache for applications, and so if you're doing something network intensive that is requiring a lot of DNS resolutions, then it's kind of expected... although I'd argue that the app causing the load is designed inefficiently as DNS resolution should be done once per connection... but I'm making an (educated) assumption about it's role in communications, plus that's not what we're here for 😛

 

If it is affecting performance:

 

Have you modified your hosts file in C:\windows\system32\drivers\etc? Also, if you open it, how many entries does it have that have an IP and an address/name?

What AVs/Firewalls do you have installed?

I know you mentioned them, but have you got all your drivers up to date? (chipset, network adapters, etc)

Have you tried using another network adapter to try and rule out that as the issue?


When it's in the high usage state:

 - can you ping google.com in cmd normally, or does it timeout/take forever before doing the first ping?

 - If you disable your AVs/Firewalls, does the issue disappear?

 - Are other devices on your network affected?

 

 

 

 

 

 


 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×