Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

VPS running OpenVPN not portforwarding properly to home server

Hi, I'm trying to get my home server to be discoverable so that I can use it to store files and do backups while I'm out of home (eg. backing up photos from a week long camping trip remotely), however, I cannot make my home server visible to the extranet because my home network is under a NAT and I share my IP address with other home networks (ISP refuses to give me a dynamic single IP without paying a hefty amount) so the next best thing that I can do is rent a $5 VPS and forward all requests directly to my home server to bypass the port blocking of my ISP. I have succesfully set up OpenVPN on the VPS, but when I try connecting it just times out the connection.

 The VPS can ping my home server through the FTP port, but when I try pinging the VPS the connection times out, meaning that for some reason my FTP request from my home network to the VPS is getting blocked.

 Here is some info about my configuration:

  •  The VPS is running Ubuntu 20.04 and OpenVPN
  •  My home server is running Arch Linux (It's the distro I'm most familiar with)
  •  The VPS service provider is Vultr.

Using the VPS as my backup server is not a viable option because my home server has 2TB of space and that same amount in a VPS is really really expensive.

Here is a diagram of how my network is set up

Screenshot_2021-08-05-44_1185x193.thumb.png.ca54937ebd3f0ca014048e2f5f4cc5dd.png

 

Here is a diagram of how I want to set up the VPS and home server.

Screenshot_2021-08-05-32_1603x302.thumb.png.683affafa172123552b58937e357b73f.png

 

 I have read some of the documents from OpenVPN but most of the info went over my head and I could not find a reliable tutorial online for my specific use case.

I think my connections are timing out because the firewall from the VPS is blocking port 21 and other ones, however, I have checked iptables and the VPS is listening to the port and it's supposed to be open, I have also tried setting up a minecraft world but it also times out. Any help is greatly appreciated!!

I use arch btw:)

Link to post
Share on other sites

I am confused, so you cant connect to your VPN? or you cant ping your VPS using VPN? Either way this sounds like your server/client firewall configuration is the issue.

mY s YsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhA t IS a GoOd FaN CuRVe??!!? wHat aRe tEh GoOd OvERclok SeTTinGS FoR My CaRd??
 HoW CaN I foRcE my GpU to uSe 1o0%? BuT WiLL i HaVE Bo0tllEnEcKs? RyZEN dOeS NoT peRfORm BetTer wItH HiGhER sPEED RaM!!dId i WiN teH SiLiCON LotTerrYyOu ShoUlD dEsHrOuD uR GPUmy SYstEm iS UNDerPerforMiNg iN WarzONEcan mY Pc Run WiNdOwS 11 ?woUld BaKInG MY GRaPHics card fIX it?
 MultimETeR TeSTiNG!! aMd'S GpU DrIvErS aRe as goOD aS NviDia's
Link to post
Share on other sites
1 hour ago, Levent said:

I am confused, so you cant connect to your VPN? or you cant ping your VPS using VPN? Either way this sounds like your server/client firewall configuration is the issue.

I want my home server to connect to the VPN so that I can bypass my ISP restrictions, however, when I ping the VPS using the VPN IP (172.27.224.1) with the port 21 or 25565 the connection times out and no data is received in the VPN, but if I ping my home server using from the VPS using the computer IP (172.27.232.4) the connection is successful and I get a response.

 The command I'm using for pinging my home server is

telnet 127.27.232.4 21

and I get the output

Trying 172.27.232.4...
Connected to 172.27.232.4.
Escape character is '^]'.

which means that the connection was succesfull, but when I try the same command with the IP 127.27.224.1 I get the output

Trying 172.127.224.1...
telnet: Unable to connect to remote host: Connection timed out

if the port were to be closed I would get :

telnet: Unable to connect to remote host: Connection refused

and using port checker it tells me the port 21 is closed on my VPS even tho I specified using iptables to open port 21.

I use arch btw:)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×