Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Motherboard not powering

I got a motherboard from Ali express for my zbook 15 g2 and tried fixing it. The motherboard after fixing, when connected to electricity is showing lights but won't come on when I tried to power it. Pls I need help urgently

Link to post
Share on other sites

Welcome to the forums!

first, are all connectors plugged in securely? Secondly, it’s likely that that motherboard is not legit. Most things from aliexpress are scams. So, by lights and not turning on, you mean it won’t post? Any irregular light patterns? Is there even a cpu under the cooler? Do you have a mechanical hard drive you could plug in to see if it spins up?

 

Is it plugged in? Is it turned on? Are you sure? No, really. 

Link to post
Share on other sites
On 8/5/2021 at 3:14 AM, Mel0nMan said:

Welcome to the forums!

first, are all connectors plugged in securely? Secondly, it’s likely that that motherboard is not legit. Most things from aliexpress are scams. So, by lights and not turning on, you mean it won’t post? Any irregular light patterns? Is there even a cpu under the cooler? Do you have a mechanical hard drive you could plug in to see if it spins up?

 

Sorry for the very late reply dude, internet connection problems. Turns out that the motherboard is half dead, power is not reaching the power cable. I have informed the buyer and I am pushing for a refund. Thanks for time, really appreciate it

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×