Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

i7-10700K random clock speeds at start up, help?

New to PCs, def CPU behavior, so bear with me...my i7-10700K normally posts with a 4.9 GHz clock, but every once in awhile it will boot up running at 5.1 GHz and will immediately thermal throttle during load/stress testing.  At first I though it was my AIO not functioning properly, all I saw was the CPU temp spikes and throttling, not noticing the higher clock speed.  But aren't CPUs supposed to vary clock speeds with in the given specs, not stay stuck at one particular clock? Anyway, I kept remounting my AIO each time telling myself I was mounting it wrong or air was in the pump until I noticed the higher clock.  The base clock is 3.8 GHz and boost 5.1 GHz per specs of this CPU, but is it just getting stuck at max boost or something during boot up?  At 4.9 GHz (its normal operating clock 98% of the time) it maybe breaks 80C max in a stress test, running steady at 60-65C during heavy gaming. but ever once in awhile it will start up running at 5.1 GHz and overheat immediately.  Anyone know whats up?

System specs:

i7-10700K

GB 3080 Ti

Aorus Z490 Elite AC

32GB Corsair Dominator RAM

PNY CS3040 2TB NVMe

Cooler Master SFX V850

Alpenfohn Glacier Water 280mm AIO

011 Mini

 

Thanks for any insight!

 

Scott

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×