Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Black Ops 3 hammering my system

I hate to make another post about this but I'm at a loss again. For about 2 weeks I've been trying to play this game at 144fps consistently (for my system that is more than possible) but nothing I have done has fixed my issues. Periodically I will jump to 90 - 100% CPU usage and drop about 40-50 frames (I've included screenshots of afterburner's OSD). I'm happy for the game to use my CPU as much as it likes but the stuttering is horrible.

https://imgur.com/a/6pFgO9n < - CPU usage spike and noticeable drop in FPS (The fps counter in the top right is a little faster than the OSD so it looks normal).

https://imgur.com/a/DqGZUxL <- Usual usage when the game feels okay to play, feels like there is a microstutter but no noticeable drop in frames.

This seems to happen when I load in a new area on the map, after that point it becomes a little smoother, however the stutter never goes away. My temps are fine for both CPU and GPU as seen in the screenshots. This doesn't happen in any other game that I can tell so I'm not too worried about there being a hardware issue but I will try anything at this point to get it working.

Solutions I have tried:

  • Above normal and high CPU priority for the exe
  • Disabling core 0 for the game (in an attempt to only allow background and general windows processes to run on that core)
  • Removing my CPU and GPU overclock
  • Updating drivers (as of the screenshots I posted my GPU drivers are up to date)
  • Trying old versions of GPU driver (I tried everyone readily available on Nvidia's site, including the initial driver for the 3060ti)
  • Disabling fullscreen optimisation
  • Running the game in Windows 8/7 compatibility mode
  • Checked my drive health, all drives are fine (my windows drive is at 79% health but speeds seem fine)
  • Optimising Nvidia control panel settings (enabling high performance mode, enabling threaded optimisation and triple buffering)
  • All variants of in-game graphics settings (medium settings slightly improve fps but stuttering is still there, I should be able to run the game on max @1440p with my setup)
  • Upping the resolution in an attempt to make the game use more of my GPU
  • Changed the hidden settings in the games config (didn't find any that helped)
  • I have reinstalled windows twice
  • Reinstalled the game
  • Verified the files through steam
  • Running no other apps apart from the game (and afterburner for the OSD)
  • Using DDU to reinstall drivers
  • High performance mode for Windows power plan and Nvidia control panel

Specs:
i7 8700k @ 4.8Ghz
RTX 3060ti w/ +60mhz core & +900mhz on memory
Asus PRIME z370a-ii
Corsair RM650 PSU
16GB DDR4 RAM @ 3000mhz
1 x 240gb SSD (Windows drive), 1 x 2tb SSD (where the game is installed) & 1 x 7200rpm HDD

Note - my friend (who has the same GPU and CPU) also has issues running the game. Their issues are that they generally get about 80fps no matter what they do. Also another friend can run this game perfectly fine with a 3080 so I don't think it's the 3000 series cards, perhaps just the 3060ti. If someone with one of those could test this game I'd appreciate that.

EDIT - Should also probably mention that around mid last year was the last time I played the game. I played on a 2070 (since swapped out for my current GPU and sold so I cant try my old card) and the game was perfectly fine from what I remember. The only thing that has changed is the new GPU, my CPU overclock and my new SSD where the game is installed.

 

Link to post
Share on other sites

Talk to the creators of the game.

Link to post
Share on other sites
Just now, FrodoX570 said:

Talk to the creators of the game.

I have submitted a ticket to Activision but I'm not expecting anything from them, the game is 6 years old almost so I imagine their technical support is more focused on their newer titles.

Link to post
Share on other sites
  • 1 month later...

I have the same issue with my 1660 ti where it drops for 50fps from 100+ for seemingly no reason since my cpu maxes out 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×