Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Static microphone starting to form over time

I have had the scarlet solo 3rd gen for about 2 years now with my AT2020 microphone, everything has been working fine and only recently have I noticed that sometimes my microphone will sound glitchy / static-like.

 

I think this is due to my XLR cable but I am not sure, I saw on a forum post that you should unplug your cable before you turn on phantom mode (48V) on the solo 3rd gen otherwise it damages the microphone, but I feel like me unplugging the microphone every day for about a year has damaged it somehow? it could even be VoiceMeeter banna, I have all my audio set to 48kHz and haven't changed any settings in VoiceMeeter for a few years now.

 

Hwelp

Link to post
Share on other sites

XLR equipment comes from the professional environment as is generally more robust, however anything can break or wear out. You could jostle the connections on the Solo side and the mic side to see if you can isolate a cabling issue.

5800x/3090

Link to post
Share on other sites
11 minutes ago, rickeo said:

XLR equipment comes from the professional environment as is generally more robust, however anything can break or wear out. You could jostle the connections on the Solo side and the mic side to see if you can isolate a cabling issue.

Ye, i wiggle the cable around and I can't seem to get it to not be static.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×